Recyle bin not emptying, DNS entries not deleted

Discussion in 'General' started by dcy747, Mar 25, 2007.

  1. dcy747

    dcy747 New Member

    Hey!

    ISPConfig 2.2.11 installed on CentOS 4.3 within OpenVZ. After some playing around (read: functional testing :) ) I've deleted all the reseller data and it's clients. However - DNS entries still remain both within the database as well as published to BIND. I know about the recycle bins and I've tried emptying all 3 of them - but emptying the "ISP Manager" recycle bins shows

    "Note: Items remaining in recycle bin after emptying are currently in update state. Please try to delete them later."

    I've tried restarting the ISPConfig, I've tried restarting the server.

    ls -al /root/ispconfig/ doesn't display any lock. The only dotfile is:

    Code:
    -rw-r--r--   1 root root     8 Mar 25 10:58 .old_path_httpd_root
    
    /home/admispconfig/ispconfig/ispconfig.log only show the following DEBUG messages:

    Code:
    25.03.2007 - 09:46:39 => DEBUG - The system is currently updating the configuration files.
    25.03.2007 - 10:20:52 => DEBUG - The system is currently updating the configuration files.
    
    Checking the ispconfig db on the mysql (just viewing, no changes were made directly to the database) shows completely empty isp_isp_domain, isp_isp_kunde, isp_isp_reseller, isp_isp_user and isp_isp_web tables (which is expected I presume).

    However. The dns_ tables are not empty.

    dns_a has 2 entries (both doctype_id 1018), one with doc_id 3 and one with doc_id 6.
    dns_dep has 3 entries (parent_doctype_id is 1016 for all three), 2 have child_doctype_id 1020 and one has child_doctype_id 1018.
    dns_isp_dns has 1 entry with doctype_id 1016
    dns_mx has 2 entries
    dns_nodes has several entries with one really being interesting, because the user_id of the entry is 3 - while there are no remaining users left (apart from the administrative account).

    The zone files for the domain.tld is still in the /var/named/chroot/var/named directory.

    I've also tried /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php
    and it only displays the "start" and "ende" lines and takes around a second to run.

    Is there anything else that I can do that doesn't involve reinstalling? ;)

    D.
     
  2. dcy747

    dcy747 New Member

    Addition ...

    Forgot to mention - ispconfig_wconf is running :)

    ps ax|grep wconf

    Code:
     3586 ?        S      0:00 /bin/bash /root/ispconfig/sv/ispconfig_wconf
    
    D.
     
  3. falko

    falko Super Moderator

    You have to delete DNS records manually in the DNS Manager. They're not deleted automatically when you delete web sites, etc. That's the intended behaviour. :)
     
  4. dcy747

    dcy747 New Member

    Ah!

    But the problem lies in the fact that the DNS manager does not show any records any more (and it's recycle bin is empty ...) :D

    Is there any way to see the data model (to see what is connected to what)? This could be a bug :(

    D.
     

Share This Page