recreating domains

Discussion in 'General' started by apex, Jan 27, 2008.

  1. apex

    apex New Member


    I've run into a situation where I wanted to remove a site, then re-add the domain as a co-domain to another site. I run into the friendly message:

    The name .domain.tld is already in use by another site or domain.

    Now I've already emptied the recycle bin and made sure it's contents where gone fo both the ISP Manager and DNS.

    I can recreate the domain as a seperate site if I like, but cannot create any co-domain that has ever previosly existed without running into this error. Any way around this?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please empty the recycle bin.
  3. apex

    apex New Member

    ?? I mentioned in my post that I had already cleared the recycle bins. There's nothing in them.
  4. falko

    falko Super Moderator ISPConfig Developer

    Please make sure that the Co-Domain isn't used by any other site on your server.
  5. apex

    apex New Member

    I've checked and re-checked every site. The domain I'm trying to add doesn't exist in any entry now. I can add www.domain.tld as a new site, but can't proceed to add domain.tld as a co-domain.
  6. apex

    apex New Member

    In addition:

    I logged into the ispconfigdb data base and looking at the isp_isp_domain table I see an entry for the domain I've removed. Did the recyle bin not delete it completely?

    If I remove the entry for it from the DB, is there anywhere else that I may need to also make edits?
  7. apex

    apex New Member

    Ok, so removing the entry from the isp_isp_domain table solved the issue.

    I'm guessing the recyle bin didn't complete it's task for some reason.

    I've added the domain successfully as a co-domain and everything appears to be running as it should.

Share This Page