Recover exented superblock

Discussion in 'Technical' started by Chocrates, Aug 27, 2011.

  1. Chocrates

    Chocrates New Member

    I was following and when i reboot and run:

    root@Microknoppix:/home/knoppix# fsck -n /dev/sda7
    fsck from util-linux-ng 2.17.2
    e2fsck 1.41.12 (17-May-2010)
    fsck.ext2: Superblock invalid, trying backup blocks...
    fsck.ext2: Bad magic number in super-block while trying to open /dev/sda7

    The superblock could not be read or does not describe a correct ext2
    filesystem. If the device is valid and it really contains an ext2
    filesystem (and not swap or ufs or something else), then the superblock
    is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

    so i ran e2fsck with all the block numbers that you need (forget exactly what tool i used to find where the superblocks are hidden) no dice

    then i ran testdisk and had it look for the superblock, no results

    anyone have any ideas?

    fdisk -l for reference:

    root@Microknoppix:/home/knoppix# fdisk -l

    Disk /dev/sda: 320.1 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x97646c29

    Device Boot Start End Blocks Id System
    /dev/sda1 1 64 512000 83 Linux
    Partition 1 does not end on cylinder boundary.
    /dev/sda2 64 38912 312046593 f W95 Ext'd (LBA)
    /dev/sda5 64 326 2104320 82 Linux swap / Solaris
    /dev/sda6 * 327 2938 20972544 83 Linux
    /dev/sda7 2938 37897 280815685 83 Linux
    /dev/sda8 37898 38912 8152956 83 Linux

Share This Page