recompile php? i need --with-sqlite=shared' '--with-pdo-sqlite=shared'

Discussion in 'Installation/Configuration' started by vwpete, Oct 21, 2011.

  1. vwpete

    vwpete New Member


    I have a ispconfig 3 on Ubuntu 10.04, i followed the install

    I have a few joomla websites working fine, I have gone to install the joomla 1.7 and use a rocketheme which needs the following specs:

    PHP support for the SQLite PDO driver
    PHP support for the MySQL PDO driver
    MySQL with InnoDB support
    PHP support for PDO
    PHP support for GD2
    PHP 5.2.8 and above

    I am getting error "The PHP Sqlite PDO driver is needed but not installed."

    i am told i need php configured with:
    --with-sqlite=shared' '--with-pdo-sqlite=shared'

    so i have looked into this and i see ispconfig compiles its own php, so how do i go about adding the above?


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The php used on your server is not manually compiled, if you want to use sqlite, then just install the php5-sqlite package from ubuntu.

    apt-get install php5-sqlite
    /etc/init.d/apache2 restart
    Last edited: Oct 21, 2011
  3. vwpete

    vwpete New Member

    correct and thanx

    yes 100% correct thanks very much that worked. i am confused and clearly out of date so i don't need to recompile php anymore. brilliant!!!

Share This Page