Recompile Centos 4.4 2.6.9-42.EL to 2.6.22

Discussion in 'Kernel Questions' started by levali_2001, Jul 20, 2007.

  1. levali_2001

    levali_2001 New Member

    good day to all.

    i am newbie to linux and i want to recompile its kernel. presently, the kernel version installed on my unit is 2.6.9-42 and i want to upgrade it to 2.6.22 since my current kernel, 2.6.9-42 does not support nvidia geforce video card unlike on 2.6.22 which supports. now i want to use this kernel 2.6.22 to use my nvidia video card. i have read a lot of tutorials but all failed. i mean, all the steps they have given does not succeed. all have errors. below were the commands and steps i have tried to execute.

    1. download the new kernel which is 2.6.22
    2. save the downloaded file on /usr/src
    3. execute "tar xvjf linux-2.6.22.tar.bz2"
    4. execute "cd linux-2.6.22"
    5.execute "make menu config"
    6. i tried to change the configuration under "device drivers-->graphics support-->nvidia support" from <M> to <*>...:cool: i selected this to include the nvidia drivers.
    7. execute "make bzImage"
    8. execute "make modules"
    9. execute "modules_install"
    10. execute "cp arch/x86_64/boot/bzImage /boot/vmlinuz-2.6.22"
    11. execute "cp /boot/"

    after i finished all this commands, i modified the grub.conf. the file look like this:

    # grub.conf generated by anaconda
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE: You have a /boot partition. This means that
    # all kernel and initrd paths are relative to /boot/, eg.
    # root (hd0,0)
    # kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
    # initrd /initrd-version.img
    title CentOS-4 x86_64 (2.6.9-42.ELsmp)
    root (hd0,0)
    kernel /vmlinuz-2.6.9-42.ELsmp ro root=/dev/VolGroup00/LogVol00 rhgb quiet
    initrd /initrd-2.6.9-42.ELsmp.img
    title CentOS-4 x86_64-up (2.6.9-42.EL)
    root (hd0,0)
    kernel /vmlinuz-2.6.9-42.EL ro root=/dev/VolGroup00/LogVol00 rhgb quiet
    initrd /initrd-2.6.9-42.EL.img

    title CentOS-5 x86_64-up (2.6.22)
    root (hd0,0)
    kernel /vmlinuz-2.6.22 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
    initrd /initrd-2.6.22.img

    but upon reboot, i got on error... And the error is this,

    1. Powernow - K8:MP systems not supported by RSB Bios structure
    2. Kernel panic - not syncing:VFS : unable to mount root fs on unknown -block(0,0)

    i tried to search also what are the causes of such errors but i can't figure out what is it.

    so i post now my message to ask help from you. thank you very much...:)
  2. falko

    falko Super Moderator ISPConfig Developer

    That's a big leap from 2.6.9 to 2.6.22. I think the biggest problem is the change from devfs to udev in newer kernels. Maybe it would be easier to upgrade to CentOS 5.0 somehow (uses the 2.6.18 kernel, I think) and then compile a new kernel.
  3. levali_2001

    levali_2001 New Member

    thanks for your reply...

    adopting centos 5.0 is a great idea. Nvidia drivers are already included in this kernel unlike centos 4.4 which uses 2.6.9-42.EL..

    However, if i used centos 5.0, my problem again is that the Digital Video Recorder (DVR) cannot be installed and run in that OS since the only OS that my DVR accepts is Centos 4.4 only.. Nothing more...

    Thats why, what I need is to recompile the kernel of Centos 4.4 (2.6.9-42) adopting kernel 2.6.18 or 2.6.22 where Nvidia drivers are included...

  4. briealeida

    briealeida New Member

Share This Page