Recipient address rejected: User unknown in local recipent table.

Discussion in 'Installation/Configuration' started by adrenalinic, Apr 21, 2006.

  1. adrenalinic

    adrenalinic Member HowtoForge Supporter

    HI.
    I have very courious problem.
    When i send email from my account, managed from my ispconfig, to mail of my friend giuseppe@friend_domain.info i have this error:

    An error occurred while sending mail.
    Tha mail server responded: giuseppe@friend_domain.info:
    Recipient address rejected: User unknown in local recipent table.
    Please verify that your email address is correct in your mail preferences and try again
    :eek:


    But if i send mail to any other mail address.....[email protected] ....[email protected]..
    send email correctly...

    :confused:

    it would seem trying to send mail to mail address to the inside of the table of the customers managed from the my ispconfig server. and it does not send the mail to the relative external domain

    :confused:
     
    Last edited: Apr 21, 2006
  2. adrenalinic

    adrenalinic Member HowtoForge Supporter

    i have tryed to send mail from web mail and have this message:

    SMTP Error: Recipient not accepted. Verify your relay rules
     
  3. adrenalinic

    adrenalinic Member HowtoForge Supporter

    mmmmmmm
    problem persist

    have tested my server at http://www.abuse.net
    and result is:

    Relay test result
    All tests performed, no relays accepted

    my address is 207.210.96.14


    this is my main.cf:


    myhostname = server1.myserver.org
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = server1.myserver.org, mail.myserver.org, localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command =
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names
     
    Last edited: Apr 21, 2006
  4. adrenalinic

    adrenalinic Member HowtoForge Supporter

    any idea?!
     
  5. falko

    falko Super Moderator ISPConfig Developer

    So mail for friend_domain.info is handled by a remote server? IS that server configured to accept mail for giuseppe@friend_domain.info?
     
  6. adrenalinic

    adrenalinic Member HowtoForge Supporter

    yes. mail giuseppe@friend_domain.info exist and i receive mail from this account and all mail from domain friend_domain.info

    domain is officinadellearti.info
     
    Last edited: Apr 22, 2006
  7. falko

    falko Super Moderator ISPConfig Developer

    I've just sent a test mail to giuseppe [at] officinadellearti.info, and it seems to have been sent successfully because I didn't get an error mail back.

    Is officinadellearti.info different from your own server? Is officinadellearti.info in /etc/postfix/local-host-names?
     
  8. adrenalinic

    adrenalinic Member HowtoForge Supporter

  9. falko

    falko Super Moderator ISPConfig Developer

    I received your reply, so the email address is working.

    What's in /etc/resolv.conf? What's the output of
    Code:
    ping -c4 officinadellearti.info
    ?
     
  10. adrenalinic

    adrenalinic Member HowtoForge Supporter

    HI.
    I have reply to your mail address with officinadellearti.eu managed from my ispconfig server.

    server1:~ # ping -c4 officinadellearti.info
    PING officinadellearti.info (217.22.228.75) 56(84) bytes of data.
    64 bytes from dell2.mondoserver.com (217.22.228.75): icmp_seq=1 ttl=52 time=129 ms
    64 bytes from dell2.mondoserver.com (217.22.228.75): icmp_seq=2 ttl=52 time=129 ms
    64 bytes from dell2.mondoserver.com (217.22.228.75): icmp_seq=3 ttl=52 time=129 ms
    64 bytes from dell2.mondoserver.com (217.22.228.75): icmp_seq=4 ttl=52 time=128 ms

    --- officinadellearti.info ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 3001ms
    rtt min/avg/max/mdev = 128.990/129.339/129.791/0.536 ms




    ___________________________________________________________________

    dig 209.51.143.76 officinadellearti.info
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39760
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;209.51.143.76. IN A

    ;; ANSWER SECTION:
    209.51.143.76. 655360 IN A 209.51.143.76

    ;; Query time: 1 msec
    ;; SERVER: 209.51.143.76#53(209.51.143.76)
    ;; WHEN: Sun Apr 23 20:26:38 2006
    ;; MSG SIZE rcvd: 47


    ; <<>> DiG 9.3.1 <<>> 209.51.143.76 officinadellearti.info
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 65216
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;officinadellearti.info. IN A

    ;; ANSWER SECTION:
    officinadellearti.info. 85157 IN A 217.22.228.75

    ;; Query time: 1 msec
    ;; SERVER: 209.51.143.76#53(209.51.143.76)
    ;; WHEN: Sun Apr 23 20:26:38 2006
    ;; MSG SIZE rcvd: 56
     
    Last edited: Apr 23, 2006
  11. adrenalinic

    adrenalinic Member HowtoForge Supporter

    my resolve.conf

    nameserver 209.51.143.76
    nameserver 209.51.143.19
    nameserver 209.51.128.20


    i see!:

    # dig www.officinadellearti.info

    ; <<>> DiG 9.3.1 <<>> www.officinadellearti.info
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4591
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;www.officinadellearti.info. IN A

    ;; ANSWER SECTION:
    www.officinadellearti.info. 86400 IN A 217.22.228.75

    ;; Query time: 132 msec
    ;; SERVER: 209.51.143.76#53(209.51.143.76)
    ;; WHEN: Sun Apr 23 20:21:33 2006
    ;; MSG SIZE rcvd: 60
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. Can you try to send again? Maybe it was a temporary DNS issue and is working now.
     
  13. adrenalinic

    adrenalinic Member HowtoForge Supporter

    dig ns 209.51.143.76 officinadellearti.info
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 24529
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;209.51.143.76. IN NS

    ;; AUTHORITY SECTION:
    . 10751 IN SOA A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. 2006042301 1800 900 604800 86400

    ;; Query time: 60 msec
    ;; SERVER: 151.99.125.1#53(151.99.125.1)
    ;; WHEN: Mon Apr 24 11:06:26 2006
    ;; MSG SIZE rcvd: 106


    ; <<>> DiG 9.3.1 <<>> ns 209.51.143.76 officinadellearti.info
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44155
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;officinadellearti.info. IN NS

    ;; ANSWER SECTION:
    officinadellearti.info. 86400 IN NS ns11.mondoserver.com.
    officinadellearti.info. 86400 IN NS ns10.mondoserver.com.

    ;; ADDITIONAL SECTION:
    ns10.mondoserver.com. 85811 IN A 217.22.228.75

    ;; Query time: 91 msec
    ;; SERVER: 151.99.125.1#53(151.99.125.1)
    ;; WHEN: Mon Apr 24 11:06:26 2006
    ;; MSG SIZE rcvd: 109
     
  14. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    telnet officinadellearti.info 25
    on your server?
     
  15. adrenalinic

    adrenalinic Member HowtoForge Supporter

    Hi Falko.
    I have already tryed to login and is all ok:

    server1:/home # telnet officinadellearti.info 25
    Trying 217.22.228.75...
    Connected to officinadellearti.info.
    Escape character is '^]'.
    220 dell2.mondoserver.com ESMTP Sendmail 8.13.1/8.13.1; Mon, 24 Apr 2006 22:24:24 +0200


    very most courious....

    it could be a lock from 217.22.228.75 that manages my domain officinadelleart.info ?
     
    Last edited: Apr 24, 2006
  16. falko

    falko Super Moderator ISPConfig Developer

    Have you asked the administrator of 217.22.228.75? (Or is it you?)
     

Share This Page