receiving other mail addresses

Discussion in 'Installation/Configuration' started by Com, Jun 4, 2009.

  1. Com

    Com New Member

    I have installed Ubuntu Server 9.04 and got my email server working. I am using dovecot-postfix with squirrelmail. Is it possible for me to configure it so i'm able to receive email from anyone? I'm able to receive only from my domain but i'm able to send to anyone.

    Thanks for the help in advance
  2. falko

    falko Super Moderator ISPConfig Developer

    Make sure that the MX record for your domain points to your server. You can check that with
    dig mx
  3. Com

    Com New Member

    mx resord

    Does this look right or do I need more entrys?

    ;; ANSWER SECTION: 3600 IN MX 0 3600 IN MX 0 3600 IN MX 0
    Last edited: Jun 5, 2009
  4. falko

    falko Super Moderator ISPConfig Developer

    One entry would be enough. Make sure there's an A record for the right part of the answer (e.g.
  5. Com

    Com New Member

    amavis-new problems

    Thank you for your help.
    I had been doing test emails from yahoo and i looked at the error message real close and it was saying that there was no MX or A record for the I went back and added that MX record and now it works.

    I would have gotten back to you sooner but I installed amavis-new, clamav, and spamassassin which messed the server up to where it wouldn't send out mail.... I uninstalled one at a time to find the culprit and it was amavis-new.
    Afer I uninstalled everything I reinstalled dovecot-postfix ( aptitude reinstall dovecot-postfix ) and squirrelmail then rebooted the server to get it back to where it was.

    Any ideas about the amavis-new.
    I used this to configure amavis-new

    My install was pretty simple I installed Ubuntu Server 9.04 with lamp, open-ssh, and mail. Then after the server install I did (aptitude install dovecot-postfix) and (aptitude install squirrelmail) and of course (aptitude install apache2) I'm just setting up a web site with email and wordpress.
  6. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?
    What's the output of
    netstat -tap
  7. Com

    Com New Member

    postfix fails after amavisd-new

    After I install amavisd-new and configure it to the above tutorial, or this one , and when I restart postfix and it comes up fail. i'm not sure which log to look at but in the /var/log/syslog it basically said postfix failed with no code. The mail log /var/log/mail.log didn't show anything usefull. Right now i have amavisd-new uninstalled and I commented out the chainges i made to the and file. When I restarted postfix it still came up fail so I reinstalled dovecot-postfix and the problem went away. So for now amavisd-new is uninstalled and my mail server is working fine. I do have clamav and spamassassin installed.
  8. falko

    falko Super Moderator ISPConfig Developer

    No errors in /var/log/mail.log?
  9. Com

    Com New Member

    Thanks again for the help
    I'll reinstall amavisd-new this weekend again and if it's still doing the same thing i'll post you the exact errors.

Share This Page