Receiving mail postfix NOQUEUE: reject: RCPT

Discussion in 'Server Operation' started by killo, Feb 28, 2013.

  1. killo

    killo New Member

    I tried allot of things, tried playing with the main.cf and more. But I constantly get the error "postfix/smtpd[27132]: NOQUEUE: reject: RCPT from... 554 5.7.1 <**email**>: Relay access denied; "

    And with some other settings I got unknown user "info".

    I can send email from the account, but cannot receive emails.

    if you need any other info please ask.

    here's my main.cf file:
    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = /usr/share/doc/postfix
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = mail.guild-tdf.nl
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = $myhostname, localhost.$mydomain, localhost
    mydestination = hash:/etc/postfix/mydomains
    #relayhost =
    mynetworks = 192.168.0.0/24, 192.168.1.0/24, 127.0.0.0/8
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2em$
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /home/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    virtual_create_maildirsize = yes
    virtual_maildir_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_ma$
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    inet_protocols = all
    mydomain = guild-tdf.nl
    #smtpd_sender_restrictions = permit_sasl_authenticated
    mail_spool_directory = /var/spool/mail
    queue_directory = /var/spool/postfix
     
  2. killo

    killo New Member

    I now get the email back (unknown user: "info")
    the message in the log :
    Code:
     to=<info@guild-tdf.nl>, relay=local, delay=0.02, delays=0.02/0/0/0, dsn=5.1.1, status=bounced (unknown user: "info")
    I do have the users maped in the main.cf and here's the file:
    Code:
    user = mailuser
    password = ****
    dbname = mail
    query = SELECT CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/') FROM users WHERE email='%s'
    hosts = 127.0.0.1
    Can anyone please help me with this ?
    I followed the guide http://www.howtoforge.com/virtual-u...courier-mysql-and-squirrelmail-debian-squeeze
    I cant figure out why I cant sent mails to this email
     
  3. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you post your main.cf? My guess is that you use the hostname guild-tdf.nl already in myorigin or myhostname which means you cannot use it in the MySQL database anymore.
     

Share This Page