Receiving external emails -connection refused

Discussion in 'Installation/Configuration' started by terryoleary1981, Jan 15, 2008.

  1. terryoleary1981

    terryoleary1981 New Member

    Hi

    I've had ISPconfig setup for a week or so and still havent managed to configure the recieving of emails (sending works). I'm not sure what i'm missing but i think i'm getting closer to the solution. I've created mx records with my registrar pointing to my server and now i get connection refused error on emails sent.

    Code:
    THIS IS A WARNING MESSAGE ONLY.
    
    YOU DO NOT NEED TO RESEND YOUR MESSAGE.
    
    Delivery to the following recipient has been delayed:
    
        admin@exampledomain.co.uk
    
    Message will be retried for 1 more day(s)
    
    Technical details of temporary failure:
    TEMP_FAILURE: Could not initiate SMTP conversation with any hosts:
    [mx10.exampledomain.co.uk.exampledomain.co.uk. (10): Connection refused]
    [mx40.123-reg.co.uk. (20): Connection refused]
    [mx30.123-reg.co.uk. (30): Connection refused]
    anyone got any pointers for me to get this working.
     
  2. terryoleary1981

    terryoleary1981 New Member

    hey all

    Anyone any ideas on this?
     
  3. jnsc

    jnsc rotaredoM Moderator

    mx10.exampledomain.co.uk.exampledomain.co.uk.

    It looks like you forgot the . at the end of your MX record
     
  4. terryoleary1981

    terryoleary1981 New Member

    indeed i did forget the dot at the end!!

    see if this makes a difference, thanks.
     
  5. terryoleary1981

    terryoleary1981 New Member

    hi

    I'm still not getting emails, been trying for about 2 weeks to get this working. I can send no problem its just the receiving.

    Can anyone guide me through setting up an email account from scratch, i'm having problems with knowing what MX records to set and where eg. with 123-reg and on ISPconfig.

    Or a link to a relevant tutorial would be a great help!
     
  6. toolish

    toolish ISPConfig Developer ISPConfig Developer

    Hi,

    A good place to start would be to check that your port 25 is open to the world, if your at the same public ip address as your server you can use the custom port test at http://www.whatsmyip.org/ports/
    If your outside of your local network you could try and telnet into port 25 at our servers public ip address, the command you need for this is simply 'telnet yourpublicIP 25'
    You should get a result like '220 server.domain.com ESMTP Postfix ' if all goes well. If you get the result connection refused then you may either have your firewall/router misconfigured or your isp maybe blocking port 25.

    As far as the DNS goes you should only need entries at 123-reg and not your server, unless you are running secondary DNS on it for the domain.

    In the 123-reg DNS management section you should add a new A record with the following details, using the terms 123-reg use, the Name should be 'mail' (without the quotes) the Type is A and the Content is your public IP address.

    Then you need to add the MX record, this should be 'mail.yourdomain.com.' (without quotes, with full stop) and set the priority to 10.

    It looks from above that you still have some MX entries for the 123-reg mail servers, this shouldn't be necessary unless maybe you are using their mail forwarding service?

    Hope it helps.
     
  7. terryoleary1981

    terryoleary1981 New Member

    Hi

    i've checked and it appears my port 25 is being blokced somewhere as i cant telnet to port 25. My router is set to have port 25 open, and port 25 seems to be open when i run a port scan in isp config. according my isp port 25 shouldnt be blocked as i have a static IP account.

    I'm a bit stumped!
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the output of:

    iptables -L

    and contact your access provider and ask them if they block port 25.
     
  9. terryoleary1981

    terryoleary1981 New Member

    hi

    The output of iptables -L is:

    Code:
    Chain INPUT (policy ACCEPT)
    target prot opt source   destination
    
    Chain FORWARD (policy ACCEPT)
    target   prot opt source  destination
    
    Chain OUTPUT (policy ACCEPT)
    target prot opt source  destination
    
    So far my conversation with my ISP has indicated that as i do have a static port 25 shouldnt be blocked. But i am checking with them again.
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you restart your router and test again?
     

Share This Page