Receiving Email and Username Problem

Discussion in 'General' started by dstme, Nov 15, 2005.

  1. dstme

    dstme New Member

    Hi,
    I tried to create an email account with the name [email protected]. On ISPConfig - User &Email, the username is prefix as web1_ . Is there anywhere I can fix this not to have a prefix? I just need username as dstme instead web1_dstme. Please help, thanks again.:)

    I have another problem, I tried to test sending email from one account to [email protected] but failure notice return. But there is no problem sending out from [email protected] using ISPConfig. Any thing that I set wrongly on ISPConfig?
     
  2. mphayesuk

    mphayesuk New Member

    1st Question if you go to the management tab on the main menu and then to settings, there is an option on one of the tabe for what the prefix is. You can delete it out of there and then you wone have it in front of any new e-mail accounts you create.
     
  3. mphayesuk

    mphayesuk New Member

    2nd: try send it to web[id[[email protected] and see if that works.
     
  4. dstme

    dstme New Member

    Thank mphayesuk! Got it.

    For everyone it is: Management>SystemConfig>Settings>ISP Manager

    But another problem. I delete the email account so I can recreate without prefix. It does not allow me to recreate, error message " The username is already in use." Any help please.
     
  5. mphayesuk

    mphayesuk New Member

    Try emptying the "trash can" and then wait for a couple of minutes... it should then allow you to re-create with same name.
     
  6. dstme

    dstme New Member

    I did empty Trash many times and also delete the whole site account and recreate. The error still pop up when I add new email with same username. Any other way?

    Also, I look at the database, it start with "web2_". I deleted as above but database still with the prefix. Can it with the prefix with account username?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Is the trash empty after you emptied it? have you emptied the trash of the correct reseller? Every Reseller and the admin have their own trash.

    Have you emtied the web prefix field under: Management > SystemConfig > Settings on the tab ISP Manager? If so, you can enter every username without a prefix, but its not recommended because the username may collide with usernames from other sites.
     
  8. dstme

    dstme New Member

    Hi Till,

    I created the client and site accounts which is shown under Site and not reseller or Client. Trash was also emptied.

    Anyway, I have deleted the whole account again and and tried again. And I make sure emptied the web prefix field under: Management > SystemConfig > Settings on the tab ISP Manager. Now, I have create a client shown under Client and website under Site. Same error message "The username is already in use".

    Also, I try to create the db, and this time database is web3_db1 and Database User: web3_u1.:confused:
     
  9. falko

    falko Super Moderator ISPConfig Developer

    That's because MySQL counts up the index, no matter if web2 has been deleted or not. No problem here.:)
     
  10. dstme

    dstme New Member

    Hi Falko,
    For DB, can I reset it and not use web1_. Can I use username instead?

    For the email, I still unable to create with the same username. Anyway to delete it permanently and recreate again?

    Also, when I emptied the prefix, I can't seem to login to FTP.
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Please check the file /home/admispconfig/ispconfig/users if your username is in there. If it is, delete it from the file, but make sure that the user doesn't exist in /etc/password and /etc/shadow either.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    No. You can reset it only when you uninstall ISPConfig, remove the database and install ISPConfig again.

    No.

    Is the user still shown in the recycle bin after you emptied it? Have you created a user with the same username on the shell before you installed ISPConfig? Is a record in the database table isp_isp_user with that username?

    The prefix has nothing to do with FTP. Emptien the prefix does not change existing usernames, it will only affect new usernames.
     
  13. dstme

    dstme New Member

    Thanks Superb! Yes found the name in the file /home/admispconfig/ispconfig/users
    Deleted and it works like charms. Just wonder why it would not delete by itself.

    I still cannot access to Web-FTP, seems username is wrong. Where can I check the username?
    FYI, under the same file /home/admispconfig/ispconfig/users, it also shows:
    web1_anonftp
    web2_anonftp
    web3_anonftp

    As from /etc/passwd it shows:
    web1_anonftp:x:12001:12001::/home/www/web1/ftp:/bin/false
    web2_anonftp:x:12002:12002::/home/www/web2/ftp:/bin/false
    web3_anonftp:x:12003:12003::/home/www/web3/ftp:/bin/false

    And /etc/shadow it shows:
    web1_anonftp:!!:13102:0:99999:7:::
    web2_anonftp:!!:13102:0:99999:7:::
    web3_anonftp:!!:13102:0:99999:7:::
     
    Last edited: Nov 15, 2005
  14. dstme

    dstme New Member

    I tried with the username to login web-ftp, but can't
     
  15. dstme

    dstme New Member

    Almost give-up.:mad:

    After able to recreate email account, I try to send email to the account, but it was returned.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log? Which distribution do you use? Did you follow any of the "Perfect Setups" on HowtoForge?
     
  17. dstme

    dstme New Member

    From /var/log:
    Anyway I can find my ftp username? I can't login with the username.

    I followed step by steps on Perfect Setup with Fedora 4.

    I think I might have to start over with ISPConfig. Can I just delete the whole folder and start over again?:confused:
     
    Last edited: Nov 15, 2005
  18. falko

    falko Super Moderator ISPConfig Developer

    Is fotonetstudio.net in /etc/postfix/local-host-names? Did you enable "Server requires authentication." in your email client?

    The username is the same as for email (normally web<id>_xxxx). It's important that you don't mix this up with the login for resellers and customers which is for ISPConfig only!
    As you are on FC4, did you have a look at this thread? http://www.howtoforge.com/forums/showthread.php?t=196
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    All usernames taht you find in the file /home/admispconfig/ispconfig/users are not managed by ISPConfig. That means you cant delete or edit them in the ISPConfig Interface. The file /home/admispconfig/ispconfig/users is created by the ISPConfig installer to protect users to be overriden by ISPConfig that where in the /etc/passwd file before ISPConfig was installed.
     
  20. dstme

    dstme New Member

    I think I better re-install ISPConfig.
    1. Do I uninstall by going to /root/ispconfig/uninstall ?
    2. And to reinstall, do I follow the steps provided by ISPConfig? Will all data in db reset?
    3.
    I have leave prefix blank.Till now, I still unable to receive email. Seems emails are not able to reach to server or has been rejected by the server.
    Thanks.
     

Share This Page