really slow website access

Discussion in 'Installation/Configuration' started by itgroup, Jul 16, 2006.

  1. itgroup

    itgroup New Member

    Hi,
    just wondering if someone can give me a few clues here. I have had ispconfig running succesfully on a CentOS system now for over a month. All is going well, however access to websites that are being hosted on the server are very slow to show up.
    I have a pretty powerful server - P4 3ghz with 2GB RAM and fast SATA HDD, with Intel fast 100 NIC, so I do not think it is hardware. My DSL connection is 1.5mb/256 - so that should be ok too.
    I am hosting 12 sites, so not a lot and the traffic to them is not that much either. But when you try to browse any of the sites (from outside my LAN of course), they are quite slow to load. These sites are not graphically intensive either.
    My logs do not show anything out of the normal.
    So, is there a way to 'tune' ispConfig or something else I can try to speed up access?
    Also, it is slow for FTP as well.
    thanks
    Steve
     
  2. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    Maybe i'm wrong but it sounds like your connection. I had previous server on 1/125 adsl and it was always slow. Considering 125 is about 25kb/s having 5 visitors on website can make a huge load for line.. I only had 1 website on that server..

    Check your upload connection.. If you have 12 sites on it it doesn't require a lot of traffic..

    Uh oh, get munin stats and check the traffic.
     
  3. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    So from inside your LAN it's fast enough? Then it might also be your router's firewall.
    As TheRudy suggested, you should install munin and check the traffic graph.
     

Share This Page