Real-time Blackhole List does not update main.cf

Discussion in 'ISPConfig 3 Priority Support' started by elmacus, Nov 19, 2019.

Tags:
  1. elmacus

    elmacus Member HowtoForge Supporter

    I have problem with GUI Server config: Real-time Blackhole List, changing, removing or adding does nothing in main.cf.
    Gui Monitor Data log history:
    realtime_blackhole_list=blzen.spamchaus.op.netrg (Color coded, so correct)
    Debug mode shows this:
    DEBUG - Replicated from master: REPLACE INTO `server`:
    \nrealtime_blackhole_list=zen.spamhaus.org
    DEBUG - Calling function 'update' from plugin 'postfix_server_plugin' raised by event 'server_update'.
    DEBUG - Calling function 'restartPostfix' from module 'mail_module'.
    Then:
    #postconf -h smtpd_recipient_restrictions
    permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_rbl_client bl.spamcop.net, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, check_recipient_access mysql:/etc/postfix/mysql-virtual_policy_greylist.cf
    diff main.cf main.cf~ , shows nothing.

    So what to look for ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use any custom postfix config files in conf-custom or did you manually alter postfix main.cf? It might be that ispconfig is not able to change that setting anymore when the file has been customized.
     
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I have not gotten that blacklisting to work using GUI. I add manually new reject_rbl_client to main.cf, and modify /usr/local/ispconfig/server/conf-custom/install/debian_postfix.conf.master accordingly.
     
    elmacus likes this.
  4. elmacus

    elmacus Member HowtoForge Supporter

    Well ofc we change that file, but the code you run is postconf -e, so it should only affect that row ??
    $app->system->exec_safe("postconf -e ?", 'smtpd_recipient_restrictions = '.implode(", ", $new_options));
    https://git.ispconfig.org/ispconfig...ugins-available/postfix_server_plugin.inc.php

    I did remove that line smtpd_recipient_restrictions, and did an ispconfig_update. It fixed the line, but no change to RBL.
    No conf-custum, since i want to get back on track, and avoid exactly what also Taleman is doing.
     
    Last edited: Nov 19, 2019
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, I'll check that.
     

Share This Page