Re: Can't Connect on 8080

Discussion in 'Installation/Configuration' started by rylangrant, Feb 3, 2010.

  1. rylangrant

    rylangrant New Member

    Hi, I'm using ISPConfig 3 on CentOS 5.4. I followed the the "The Perfect Server - CentOS 5.4 x86_64 [ISPConfig 3]" for this 5.4 and I ran into a few issues (had to change the one php file used in the install to CentOS 5.4 as it only listed upto 5.3). I finally got the install to go smoothly and I can access the /webmail and /phpmyadmin but I cannot access the ISPConfig login page on 8080. I don't have any firewalls/iptables running and I can nmap the system from a remote computer and see that there is something listening on 8080. I've checked the /etc/apache2/sites-enabled/000-ispconfig.vhost file and the port is set to 8080.

    I also have a problem starting up pure-ftpd but but I'm pretty sure this is un-related and will deal with that after.

    The output of iptables -L is:
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    fail2ban-ssh tcp -- anywhere anywhere tcp dpt:ssh

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain fail2ban-ssh (1 references)
    target prot opt source destination
    RETURN all -- anywhere anywhere


    The output of of netstat -tap is:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdomain:10024 *:* LISTEN 5908/amavisd (maste
    tcp 0 0 localhost.localdomain:10025 *:* LISTEN 5991/master
    tcp 0 0 *:mysql *:* LISTEN 5836/mysqld
    tcp 0 0 localhost.local:dyna-access *:* LISTEN 5740/clamd
    tcp 0 0 virtual.saskjazz.c:webcache *:* LISTEN 6004/httpd
    tcp 0 0 virtual.saskjazz.com:domain *:* LISTEN 5868/mydns
    tcp 0 0 ip-97-74-204-165.ip.:domain *:* LISTEN 5868/mydns
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 5868/mydns
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 5718/cupsd
    tcp 0 0 *:smtp *:* LISTEN 5991/master
    tcp 0 0 *:pop3s *:* LISTEN 5939/couriertcpd
    tcp 0 0 *:pop3 *:* LISTEN 5933/couriertcpd
    tcp 0 0 *:imap *:* LISTEN 5920/couriertcpd
    tcp 0 0 *:http *:* LISTEN 6004/httpd
    tcp 0 0 localhost6.localdoma:domain *:* LISTEN 5868/mydns
    tcp 0 0 *:ssh *:* LISTEN 5708/sshd
    tcp 0 0 *:https *:* LISTEN 6004/httpd
    tcp 0 0 *:imaps *:* LISTEN 5927/couriertcpd


    Any help, ideas or suggestsions would be appreciated, I've googled and checked all of the forums and solutions and I'm not having any luck right now. I've also tried downloading /reinstalling ISPConfig.

    Thanks!
     
  2. prisfeo

    prisfeo New Member

    hi,

    assuming that port 8080 is not blocked by any fw:
    if your server is (example in order to explain):
    http://server1.example.com:8080

    check DNS resolution of server1.example.com
    that must point to the ip setup in ispconfig..

    and do the following test:

    browse to:
    http://IP_setup_into_ISPconfig_during_configuration:8080

    in order to bypass "dns" resolution problems..
    even if i think it's right since you can access to webmail, phpmayadmin

    other tests:
    from a command prompt do a telnet session from a machine to ispconfig server:
    telnet IP_setup_into_ISPconfig_during_configuration 8080
    and see if you can see the curson blinking in the top left
    (-> ok) or "connection failed"

    do the same telnet test inside server itself
     
    Last edited: Feb 3, 2010
  3. rylangrant

    rylangrant New Member

    If I try going to the http://theServerIP:8080, no luck.

    If I telnet in from a remote machine to either the domain, or theServerIP on 8080 it times out

    If i telnet locally from the server into either the domain or theServerIP on 8080 I do get the HTML info echoed back.

    I'm assuming that implies that there is some kind of firewall or something blocking it? It is a virtual server with Godaddy so there is no router/NAT blocking it and I don't think there should be any firewalls on their side. Any suggestions?

    Thanks!
     
  4. till

    till Super Moderator

    As you dont run a firewall on your server, you will ahve to ask godaddy if they block port 8080.
     
  5. rylangrant

    rylangrant New Member

    Assuming they do block port 8080 i should be able to just go in via another port, right? What is the best way to change the listening port?
     
    Last edited: Feb 3, 2010
  6. prisfeo

    prisfeo New Member

    i think you can easily try to set another port(change the "8080" value) inside your:
    /etc/apache2/sites-enabled/000-ispconfig.vhost
    and restart apache.

    but you have to ensure tahe the "new" port
    is opened/reachable and not blocked from outside
    your ispconfig server
    and ensure the new port is not already used by other services
     

Share This Page