Re: BIND 9 Vulnerability And Solution - Patch BIND To Avoid Cache Poisoning (Fedora/

Discussion in 'HOWTO-Related Questions' started by jgc94131, Aug 7, 2008.

  1. jgc94131

    jgc94131 New Member

    I've got an old server running FC4 with Plesk 8.4. I've built the FC9 bind RPMs from source following the excellent instructions but when I go to update the RPMs that I have installed, I get:

    Code:
    # rpm -Uvh bind-9.5.0-33.P1.i386.rpm bind-chroot-9.5.0-33.P1.i386.rpm bind-libs-9.5.0-33.P1.i386.rpm bind-utils-9.5.0-33.P1.i386.rpm 
    error: Failed dependencies:
    	chkconfig >= 1.3.26 is needed by bind-9.5.0-33.P1.i386
    	libdns.so.20 is needed by bind-libs-9.5.0-33.P1.i386
    	libisc.so.9 is needed by bind-libs-9.5.0-33.P1.i386
    	libisccc.so.0 is needed by bind-libs-9.5.0-33.P1.i386
    #
    
    Yum reports that I have:
    Code:
    Name   : chkconfig
    Arch   : i386
    Version: 1.3.23
    
    And I seem to have the libs required in /usr/lib already.

    What do I do next?

    Thanks.
    --Jim
     
  2. topdog

    topdog Active Member HowtoForge Supporter

    Your chkconfig is a lower version that is why i do not think it really is system affecting if you install with --nodeps
     

Share This Page