rdiff backup works only with "permit root login" on master server

Discussion in 'HOWTO-Related Questions' started by adrenalinic, Oct 15, 2007.

  1. adrenalinic

    adrenalinic HowtoForge Supporter

    Hello.
    I have followed the tutorial about automated backup with rdiff.

    I have settingup a same ubuntu vps version of master and have followed the rdiff tutorial of this wonderful site ;)

    Automated backup works without any password only if setting "YES" the "permit root login" within ssh config file.

    There is a solution for setting remote root login to NO and works with rdiff?

    Very Thanks.
    Josef
     
  2. falko

    falko Super Moderator

    No, because rdiff-backup must log in as root to preserve the correct file permissions.
     

Share This Page