rdiff-backup include-globbing-filelist error

Discussion in 'Installation/Configuration' started by Lotek, Jun 4, 2008.

  1. Lotek

    Lotek New Member

    So now I've got everything else setup perfectly right, BUT now I can't get rdiff-backup to work with my external hard drive. At first it was because I was using a directory with data in it already, but now it seems that it doesn't want to read my include file. Here's my script that I've been working with:
    ## Script Variables ##
    # Backup Device #
    # Sources to backup #
    SOURCES="--include-globbing-filelist /home/user/scripts/include_file"
    # Target Directory #
    # exclude trailing slash #
    # Exclude File #
    # Extras #
    # When did the script last run
    # See what packages are installed
    ## Verify Device and Sources ##
    echo " Starting backup..."
    # -x returns true if the file exists and is executable.
    if [ ! -x $TARGET ]; then
            echo " Backup target does not exist or you don't have permission!"
            echo " Exiting..."
            exit 2
            echo " Verifying Sources..."
                    for source in $SOURCES; do
            echo " Checking $source..."
                    if [ ! -x $source ]; then
            echo " Error with $source!"
            echo " Directory either does not exist, or you do not have proper permissions."
                    exit 2
    # -f returns true if the file exists and is a regular file.
            if [ -f $EXCLUDE_FILE ]; then
            EXCLUDE="--exclude-globbing-filelist $EXCLUDE_FILE"
    ## Actual Backup ##
    echo " Sources verified. Running rdiff-backup..."
    echo " "
    echo " This may take a while..."
    echo " "
    echo " May I suggest a nice cup of coffee "
    echo " while you are waiting?"
    echo " "
            sudo rdiff-backup -v5 --print-statistics --remove-older-than 4w $EXCLUDE $SOURCES $TARGET
    ## Script Extras ##
    # Log of when I last ran the script
    # and a list of every package installed
    # on my computer.
            date +'%F_%H:%M' >> $HISTORY_LOG
            dpkg -l | awk '(print $2)' > $DPKG_LIST
    ## Disc Information ##
    # How much space do I have left?
    echo " "
    echo " Displaying Drive Information:"
            df -h
    echo " "
    exit 0
    Alright... So that throws me an error no matter what I change... ok, so then I tried to run it straight from the command line with this:

    sudo rdiff-backup -v5 --print-statistics --include-globbing-filelist ./include_file / /media/backup/rdiff_backup
    But that gives me this error message:
    Reading globbing filelist ./include_file
    Fatal Error: Last selection expression:
        Command-line include glob: /root/ispconfig
    only specifies that files be included.  Because the default is to
    include all files, the expression is redundant.  Exiting because this
    probably isn't what you meant.
    So I took out the /root/ispconfig, but then it throws the same error for my next directory name. Here is my include file:

    I'm lost in the sauce. I have no clue what is going on here and it's frustrating. So what Iam I doing wrong? I know it's probably something stupid. Oh! All of my files are edited with nano using the -w option because I just never got comfortable with vi. I can use it, but I'm not fluent with it. Regardless. Any help would be appreciated!
  2. falko

    falko Super Moderator ISPConfig Developer

    sudo rdiff-backup -v5 --print-statistics --include-globbing-filelist ./include_file [B][COLOR="Red"]/[/COLOR][/B] /media/backup/rdiff_backup
    I think you're trying to back up everything (/), therefore there's no need to include files/directories because they are included anyway.

Share This Page