rc-local.service failed

Discussion in 'Installation/Configuration' started by pecka33, Oct 11, 2021.

  1. pecka33

    pecka33 Member

    Any idea why rc-local.service is failed?

    Code:
    [email protected]:~# systemctl status rc-local
    ● rc-local.service - /etc/rc.local Compatibility
         Loaded: loaded (/lib/systemd/system/rc-local.service; enabled-runtime; vendor preset: enabled)
        Drop-In: /lib/systemd/system/rc-local.service.d
                 └─debian.conf
         Active: failed (Result: exit-code) since Mon 2021-10-11 09:38:46 CEST; 2s ago
           Docs: man:systemd-rc-local-generator(8)
        Process: 6021 ExecStart=/etc/rc.local start (code=exited, status=1/FAILURE)
            CPU: 23ms
    
    Oct 11 09:38:46 vm28069 systemd[1]: Starting /etc/rc.local Compatibility...
    Oct 11 09:38:46 vm28069 rc.local[6024]: ./resizehdd.sh: line 23: fdisk: command not found
    Oct 11 09:38:46 vm28069 rc.local[6022]: pocet /dev/sda* - /dev/vda* - /dev/hda* neni roven 2
    Oct 11 09:38:46 vm28069 systemd[1]: rc-local.service: Control process exited, code=exited, status=1/FAILURE
    Oct 11 09:38:46 vm28069 systemd[1]: rc-local.service: Failed with result 'exit-code'.
    Oct 11 09:38:46 vm28069 systemd[1]: Failed to start /etc/rc.local Compatibility.
    
     
  2. pecka33

    pecka33 Member

    Get this error after upgrade this package
    Code:
    Upgrade: reportbug:amd64 (7.10.3, 7.10.3+deb11u1), libperl5.32:amd64 (5.32.1-4+deb11u1, 5.32.1-4+deb11u2), libpam-runtime:amd64 (1.4.0-9, 1.4.0-9+deb11u1), krb5-locales:amd64 (1.18.3-6, 1.18.3-6+deb11u1), libgssapi-krb5-2:amd64 (1.18.3-6, 1.18.3-6+deb11u1), mariadb-server:amd64 (1:10.5.11-1, 1:10.5.12-0+deb11u1), libatk-wrapper-java-jni:amd64 (0.38.0-2, 0.38.0-2+deb11u1), apache2-suexec-pristine:amd64 (2.4.48-3.1+deb11u1, 2.4.51-1~deb11u1), perl:amd64 (5.32.1-4+deb11u1, 5.32.1-4+deb11u2), libapr1:amd64 (1.7.0-6, 1.7.0-6+deb11u1), galera-4:amd64 (26.4.8-1, 26.4.9-0+deb11u1), python3-reportbug:amd64 (7.10.3, 7.10.3+deb11u1), libkrb5support0:amd64 (1.18.3-6, 1.18.3-6+deb11u1), libhdf5-openmpi-103-1:amd64 (1.10.6+repack-4, 1.10.6+repack-4+deb11u1), mariadb-server-core-10.5:amd64 (1:10.5.11-1, 1:10.5.12-0+deb11u1), apache2-data:amd64 (2.4.48-3.1+deb11u1, 2.4.51-1~deb11u1), apache2-bin:amd64 (2.4.48-3.1+deb11u1, 2.4.51-1~deb11u1), apache2-doc:amd64 (2.4.48-3.1+deb11u1, 2.4.51-1~deb11u1), libc6:amd64 (2.31-13, 2.31-13+deb11u2), locales:amd64 (2.31-13, 2.31-13+deb11u2), libkrb5-3:amd64 (1.18.3-6, 1.18.3-6+deb11u1), libpam-modules:amd64 (1.4.0-9, 1.4.0-9+deb11u1), linux-image-amd64:amd64 (5.10.46-5, 5.10.70-1), base-files:amd64 (11.1, 11.1+deb11u1), libk5crypto3:amd64 (1.18.3-6, 1.18.3-6+deb11u1), jailkit:amd64 (2.21-4, 2.21-4+deb11u1), rsync:amd64 (3.2.3-4, 3.2.3-4+deb11u1), mariadb-client-10.5:amd64 (1:10.5.11-1, 1:10.5.12-0+deb11u1), mariadb-common:amd64 (1:10.5.11-1, 1:10.5.12-0+deb11u1), libpam-modules-bin:amd64 (1.4.0-9, 1.4.0-9+deb11u1), apache2-utils:amd64 (2.4.48-3.1+deb11u1, 2.4.51-1~deb11u1), libc-dev-bin:amd64 (2.31-13, 2.31-13+deb11u2), perl-base:amd64 (5.32.1-4+deb11u1, 5.32.1-4+deb11u2), libpam0g:amd64 (1.4.0-9, 1.4.0-9+deb11u1), libc-l10n:amd64 (2.31-13, 2.31-13+deb11u2), libmariadb3:amd64 (1:10.5.11-1, 1:10.5.12-0+deb11u1), libc-bin:amd64 (2.31-13, 2.31-13+deb11u2), libc-devtools:amd64 (2.31-13, 2.31-13+deb11u2), apache2:amd64 (2.4.48-3.1+deb11u1, 2.4.51-1~deb11u1), mariadb-client:amd64 (1:10.5.11-1, 1:10.5.12-0+deb11u1), libc6-dbg:amd64 (2.31-13, 2.31-13+deb11u2), libc6-dev:amd64 (2.31-13, 2.31-13+deb11u2), mariadb-server-10.5:amd64 (1:10.5.11-1, 1:10.5.12-0+deb11u1), libatk-wrapper-java:amd64 (0.38.0-2, 0.38.0-2+deb11u1), perl-modules-5.32:amd64 (5.32.1-4+deb11u1, 5.32.1-4+deb11u2), mariadb-client-core-10.5:amd64 (1:10.5.11-1, 1:10.5.12-0+deb11u1), linux-libc-dev:amd64 (5.10.46-5, 5.10.70-1)
    
     
  3. pecka33

    pecka33 Member

    Solved with

    systemctl enable rc-local.service systemctl start rc-local.service systemctl status rc-local.service
     

Share This Page