RapidSSL keeps Apache from starting

Discussion in 'Installation/Configuration' started by staticcharge, Jul 7, 2010.

  1. staticcharge

    staticcharge New Member

    I have gone through the forums here and googled this problem but I can not find an answer.

    I am running ISPConfig Version: 3.0.2.2 on the Rackspace Cloud with one virtual domain. The server runs great, Control Panel runs great, but when I try to install a RapidSSL, apache will consume 100% cpu utilization and when I reboot the server apache will not start.

    I have to a2dissite flatout-motorsports.com.vhost, reboot the server, disable the SSL from the Control Panel, apache reload, then apache restart to get everything back running.

    I have checked the logs but the only thing is see is :
    [Wed Jul 07 17:37:03 2010] [error] (9)Bad file descriptor: apr_socket_accept: (c
    lient socket)
    [Wed Jul 07 17:37:04 2010] [notice] Apache/2.2.12 (Ubuntu) PHP/5.2.10-2ubuntu6.4
    with Suhosin-Patch mod_ssl/2.2.12 OpenSSL/0.9.8g configured -- resuming normal
    operations
    [Wed Jul 07 17:37:04 2010] [warn] long lost child came home! (pid 2454)
    [Wed Jul 07 17:37:09 2010] [notice] Graceful restart requested, doing restart
    [Wed Jul 07 17:37:10 2010] [notice] Apache/2.2.12 (Ubuntu) PHP/5.2.10-2ubuntu6.4
    with Suhosin-Patch mod_ssl/2.2.12 OpenSSL/0.9.8g configured -- resuming normal
    operations
    [Wed Jul 07 17:37:10 2010] [warn] long lost child came home! (pid 2502)
    [Wed Jul 07 17:37:15 2010] [notice] caught SIGTERM, shutting down
    [Wed Jul 07 17:37:16 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/
    apache2/suexec)
    [Wed Jul 07 17:37:17 2010] [notice] Apache/2.2.12 (Ubuntu) PHP/5.2.10-2ubuntu6.4
    with Suhosin-Patch mod_ssl/2.2.12 OpenSSL/0.9.8g configured -- resuming normal
    operations
    [Wed Jul 07 17:37:32 2010] [notice] caught SIGTERM, shutting down
    [Wed Jul 07 17:37:33 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/
    apache2/suexec)
    [Wed Jul 07 17:37:34 2010] [notice] Apache/2.2.12 (Ubuntu) PHP/5.2.10-2ubuntu6.4
    with Suhosin-Patch mod_ssl/2.2.12 OpenSSL/0.9.8g configured -- resuming normal
    operations

    Any help would be appreciated.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    How did you create the CSR, and how did you install the certificate?
     
  3. staticcharge

    staticcharge New Member

    I entered the Company info, selected "Create" from the drop down, hit the Save button. After Cron did its thing I copied the CSR to GeoTrust, let it do its thing then copied the cert from GeoTrust to the SSL Cert box, selected "Save" from the drop down, then hit the Save button.

    On further reading I have seen it posted that each SSL needs its own IP. I have used the server public IP, should I assign the domain its own public IP? If this is the case, is the cert still valid with a new IP.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    The certificate is not bound to an IP. If there's already another SSL web on that IP, you must change the IP because you can have only one SSL web per IP.
     
  5. staticcharge

    staticcharge New Member

    The only other web apps on the server are the ISPConfig Control Panel and webmail. Niether use a SSL. Any ideas where I can look for a clue to what is going on? Do you think this could be unique to a Cloud Server?

    One other thing, the self signed cert works fine.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    I'd contact the RapidSSL support and ask if they know this kind of problem and if they have a solution for it.
     
  7. staticcharge

    staticcharge New Member

    GeoTrust can not identify the problem, is there someone from ISPConfig that I can hire to take a closer look?
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Yes, write an email to Till: info [at] projektfarm [dot] de
     

Share This Page