RapidSSL how to?

Discussion in 'Installation/Configuration' started by dolmax, Nov 5, 2009.

  1. dolmax

    dolmax New Member

    I have traced previous messages for an answer on how to import a RapidSSL certificate to my root server, and could not find a solution.

    1. In most of the messages and guides, users mention that they "activate SSL" on the site preference, and a new tab called SSL pops-up. My major problem is when I try to enable SSL on the preference, I get the following error "There's already an SSL certificate associated with this IP".
    2. I have tried adding "SSLCACertificateFile /home/www/www.yourdomain.tld/ssl/ca.txt" (of course with correct path of the the ca.txt file that I have created) to Apache Directives section. httpd failes for handshake issues.

    Before I have created the certificate at RapidSSL, I have re-issued the self-made certificate. Then I used the crs file to create the certificate. When I copied the crs text to RapidSSL's system, it provided the exact same output that depicted my answers.

    Can you please point me to the right direction?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can have only one ssl enabled site per IP address, thats a limit of the ssl protocol. As you have enabled SSL now for another site, go to this site, disable ssl and then enabe it on the new site. Or use a different IP address for the new site.
  3. dolmax

    dolmax New Member

    Till thank you for an answer.

    My problem is, I don't know how I can;
    1. delete the selfsigned root SSL certificate
    2. enable SSL tab for the root domain
    3. install new RapidSSL key?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Go to the website were you enabled ssl, disable the ssl chcekbox, click on save.
  5. dolmax

    dolmax New Member

    Till that's the problem.

    In the main page of my root site the "SSL" is not checked. If I try to enable SSL, I get "An SSL certificate does already exist for this IP" notification. There's no SSL tab.

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I told you to disable the ssl checkbox on the other site first!

Share This Page