RAID-1 Questions

Discussion in 'Installation/Configuration' started by etpoole60, Mar 21, 2017.

  1. etpoole60

    etpoole60 New Member HowtoForge Supporter

    I'm running CentOS 6.8 x86_64.
    The system has 4 disk like drives:
    2 - 120 GB PNY SSD drives
    2 - 4 TB WD spinning hard drives

    I've since learned that smartd 5.43 doesn't like these SSD drives - What is a good replacement?
    I've also learned the fdisk doesn't like 4 TB hard drives- although the installation allowed my for break it down to 5 partitions defined as LVM Physical volumes and raid-1 them with no issues - my second question is where can I find a document that will show me how to do what I did with fdisk but use GNU Parted?

    Does CentOS 7 have these same issues?

    TIA
    Gene
     
  2. vk3heg

    vk3heg Member

    Tell smartmon what drives you want to monitor.. ie:

    # The word DEVICESCAN will cause any remaining lines in this
    # configuration file to be ignored: it tells smartd to scan for all
    # ATA and SCSI devices. DEVICESCAN may be followed by any of the
    # Directives listed below, which will be applied to all devices that
    # are found. Most users should comment out DEVICESCAN and explicitly
    # list the devices that they wish to monitor.
    #DEVICESCAN -d removable -n standby -m root -M exec /usr/share/smartmontools/smartd-runner
    /dev/sda -m root -M exec /usr/share/smartmontools/smartd-runner
    /dev/sdb -m root -M exec /usr/share/smartmontools/smartd-runner
     
  3. sjau

    sjau Local Meanie Moderator

    What do you actually want to achieve?
     
  4. etpoole60

    etpoole60 New Member HowtoForge Supporter

    I have the following machine:
    ASUS X99 Extreme 4; Intel Core I7-5820 processor; 64 GB RAM; 2 - 120GB PNY SSD drives (sda and sdb); 2 - 4TB WD Black drives (sdc and sdd configured using gdisk)
    Running CentOS 6.8 x86_64 (I chose this because I've been trained on RHEL 5 and RHEL 6)

    What I'm trying to solve is the fact that this machine will abort and power off based upon a hardware error that I can't find. Until I find the reason I can't use this machine for production.
    I will investigate any suggestions to locate the error.

    TIA
    Gene
     
  5. sjau

    sjau Local Meanie Moderator

    and what makes you think it's a problem with RAID? Is it hardware raid or software raid?
     
  6. etpoole60

    etpoole60 New Member HowtoForge Supporter

    It's software RAID. I have learned some things: 1.) CentOS 6 install does not tell you that a 4TB drive is to big for fdisk and would use gdisk instead. 2.) smartmon does not work on PNY SSD drives. It installs and attempts to monitor anyway. 3.) For some reason my Intel 82571EB Quad port NIC doesn't function unless the machine is cold started (there goes my ifcfg-br0 and ifcfg-br1 for my KVM).
    I corrected the above (including turning off selinux) and the machine will run for hours as long as it is doing something. But if you let it sit idle for longer than 40 minutes it receives those hardware error messages and terminates.
    BTW, I found out about the warm start issue when I turned off selinux.
    The RAID issue was because of the fdisk issue with the 4 TB drives.
    TIA
    Gene
     
  7. etpoole60

    etpoole60 New Member HowtoForge Supporter

    Just as a FYI,
    mcelog does not work on a AMD Athlon II 1055t (6-core) you get a CPU not supported mesage at startup

    TIA
    Gene
     

Share This Page