quotaon: Quota format not supported in kernel.

Discussion in 'Installation/Configuration' started by bjarne-j, Oct 5, 2008.

  1. bjarne-j

    bjarne-j New Member

    Hello,

    I'm trying to install Quota my XEN VPS running Debian Etch.

    When I run "quotaon -avug" as described in "The perfect server" guide I get following error:

    Code:
    quotaon: using //quota.group on /dev/sda1 [/]: No such process
    quotaon: Quota format not supported in kernel.
    quotaon: using //quota.user on /dev/sda1 [/]: No such process
    quotaon: Quota format not supported in kernel.
    By searching this site I found another thread which covers the same issue:

    http://www.howtoforge.com/forums/showthread.php?t=233

    Trying to solve this issue I've tried following

    Code:
    modprobe quota_v1
    modprobe quota_v2
    and adding quota_v1 + quota_v2 to /etc/modules.

    It doesn't work at all. My VPS provider suggest that running following might work:

    Code:
    apt-get install mod-init-tools
    with following error:

    Code:
    E: Couldn't find package mod-init-tools
    Which repository provides the mod-init-tools package?

    Otherwise I have to compile a new kernel. I have no experience doing that and I have no configuration file in /boot. So I guess that compiling a new kernel wouldn't be an easy task for a novice.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please try
    Code:
    touch /[B]a[/B]quota.user /[B]a[/B]quota.group
    chmod 600 /[B]a[/B]quota.*
    instead of
    Code:
    touch /quota.user /quota.group
    chmod 600 /quota.*
     
  3. bjarne-j

    bjarne-j New Member

    Does this mean that quota is running properly?

    Free to ask what the "a" does for quota?

    Code:
    srv:~# touch /aquota.user /aquota.group
    srv:~# chmod 600 /aquota.*
    srv:~# mount -o remount /
    srv:~# quotacheck -avugm
    quotacheck: WARNING -  Quotafile //aquota.user was probably truncated. Cannot save quota settings...
    quotacheck: WARNING -  Quotafile //aquota.group was probably truncated. Cannot save quota settings...
    quotacheck: Scanning /dev/sda1 [/] done
    quotacheck: Checked 1524 directories and 16552 files
    srv:~# quotaon -avug
    /dev/sda1 [/]: group quotas turned on
    /dev/sda1 [/]: user quotas turned on
    
     
  4. radim_h

    radim_h Member HowtoForge Supporter

    Yes, those first time warning messages are OK...

    aquota is used on Redhat like systems
    quota is used on Debian like systems
    there is no difference in function, just different syntax.. you can try "repquota -a" command to see actual quotas on your system
     

Share This Page