quotaon not working

Discussion in 'ISPConfig 3 Priority Support' started by unsichtbare, Aug 28, 2019.

  1. unsichtbare

    unsichtbare Member HowtoForge Supporter

    Got this doing a "The Perfect Server" build on Ubuntu 18.04 - hosted on UpCloud
    Any ideas?
    THX
    -J
    Code:
    [email protected]:~# quotaon -avug
    quotaon: using //quota.group on /dev/vda1 [/]: No such process
    quotaon: Quota format not supported in kernel.
    quotaon: using //quota.user on /dev/vda1 [/]: No such process
    quotaon: Quota format not supported in kernel.
    [email protected]:~#
    
    /etc/fstab looks like this:
    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    # / was on /dev/vda1 during installation
    UUID=ebbf50b4-0252-4c26-add3-c7fc101e167f /               ext4    errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0       1
    
    
     
    Last edited: Aug 28, 2019
  2. unsichtbare

    unsichtbare Member HowtoForge Supporter

    Impatient me, I applied the suggestions in: https://techglimpse.com/quota-format-not-supported-kernel-ubuntu/
    and now get this:
    Code:
    [email protected]:~# quotacheck -avugm
    quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
    Please turn quotas off or use -f to force checking.
    [email protected]:~# quotaon -avug
    quotaon: using //quota.group on /dev/vda1 [/]: Device or resource busy
    quotaon: using //quota.user on /dev/vda1 [/]: Device or resource busy
    [email protected]:~# vi /etc/fstab
    [email protected]:~#
    
    I'm gonna stop here and wait for advice.
    THX
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to reboot the VM.
     
  4. unsichtbare

    unsichtbare Member HowtoForge Supporter

    Code:
    [email protected]:~# cat /proc/modules | grep -i quota
    quota_v2 16384 2 - Live 0xffffffffc0380000
    quota_tree 20480 1 quota_v2, Live 0xffffffffc01eb000
    quota_v1 16384 0 - Live 0xffffffffc012a000
    [email protected]:~# quotaon -pa
    group quota on / (/dev/vda1) is on
    user quota on / (/dev/vda1) is on
    project quota on / (/dev/vda1) is off
    [email protected]:~#
    
    No joy - same exact result
     
  5. unsichtbare

    unsichtbare Member HowtoForge Supporter

    I did this:
    Code:
    [email protected]:~# quotaoff /
    and now get this:
    Code:
    [email protected]:~# quotacheck -avugm
    quotacheck: Scanning /dev/vda1 [/] done
    quotacheck: Checked 20559 directories and 117821 files
    [email protected]:~# quotaon -avug
    /dev/vda1 [/]: group quotas turned on
    /dev/vda1 [/]: user quotas turned on
    
    Am I now good to move forward?
    THX
     
  6. unsichtbare

    unsichtbare Member HowtoForge Supporter

    OK - if I manually execute: quotaoff / the results look correct as compared with "The Perfect Server" (see very last post)
    But after a reboot I am back to the same 'device or resource busy' warnings. (just like in post #2 in this thread)
    Looks to me that quota is applied to / and needs to be applied to /dev/vd1
    How do I accomplish that?
    THX
     
    Last edited: Aug 29, 2019
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    /dev/vd1 is /, so that's ok. Proceed with the next steps.
     
  8. unsichtbare

    unsichtbare Member HowtoForge Supporter

    Yes, but after every reboot, I'm back to:
    Code:
    [email protected]:~# quotacheck -avugm
    quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
    Please turn quotas off or use -f to force checking.
    [email protected]:~# quotaon -avug
    quotaon: using //quota.group on /dev/vda1 [/]: Device or resource busy
    quotaon: using //quota.user on /dev/vda1 [/]: Device or resource busy
    
    Will quotas work properly with the above?

    only after I run: quotaoff / do I get:
    Code:
    [email protected]:~# quotaoff /
    [email protected]:~# quotacheck -avugm
    quotacheck: Scanning /dev/vda1 [/] done
    quotacheck: Checked 20559 directories and 117822 files
    [email protected]:~# quotaon -avug
    /dev/vda1 [/]: group quotas turned on
    /dev/vda1 [/]: user quotas turned on
    
    How do I get the post quotaoff / results after every reboot?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Do not rerun the quota commands after you rebooted. quota is already on and when you run quotacheck or quotaon again, theny they must fail. Proceed with the next steps.
     
  10. unsichtbare

    unsichtbare Member HowtoForge Supporter

  11. unsichtbare

    unsichtbare Member HowtoForge Supporter

  12. till

    till Super Moderator Staff Member ISPConfig Developer

    This package is not required on normal servers. The issue occurred because your hoster did not install the standard Linux kernel, he used a limited virtual kernel and then forgot to install this package in his virtual machine.
     

Share This Page