quotacheck many many errors-hangs program

Discussion in 'Installation/Configuration' started by Al1937, Jul 4, 2009.

  1. Al1937

    Al1937 New Member

    Tried Server 9.0.4 and 8.04.3 LTS
    Followed direction of both "Perfect Servers " using
    puTTy and copy and paste.
    Can't get quotacheck to work.
    I have not a clue.
    I am stopped and can't go any further until I resolve this.
    Help please.

    note: the code in the fstab file in "Perfect Server" instructions is different then the fstab file in the actual program?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What exactly did you do? What's in your fstab? What's the output of
    Code:
    mount
    ?
    What errors do you get?
     
  3. Al1937

    Al1937 New Member

    1, I downloaded the latest iso of Ubuntu Server 8.04.3 LTD
    2, Made a bootable copy
    3, Went through the basic install on the server computer.
    4, Brought up " The perfect server 8.04" webpage on my workstation.
    5, Using PuTTy on my work station I began a copy and paste
    from "The perfect server 8.04" . Got to apt-get install quote,
    OK.
    6, Did a vi /etc/fstab
    The contents of the fstab file as shown in the perfect server 8.04 is much different then the contents of vi /etc/fstab
    There is a line that does match, that's where I inserted usrquota,grpquota , did Esc , :w, :q
    7, Did a copy and paste of the next 3 instruction.
    8, Copy and pasted the checkquota instruction.
    9, One of the erros was:
    Scanning /dev/mapper/server1-root
    Error 2133571361
    also
    Syntax error near unexpected token 'newline'
    also
    Pages and pages of statements example:
    [2754.916612] ata2.00: status: { DRDY ERR }
    [2754.916938] ata2.00: error: { UNC }

    Is there a way I can send you the contents of mount without having to type it?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    You can copy it from your SSH/terminal window.

    What's in /etc/fstab?
     
  5. Al1937

    Al1937 New Member

    This is what the file looks like in perfect-server-ubuntu8.04-lts-p4
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/sda1
    UUID=6af53069-0d51-49be-b275-aeaea8d780c5 / ext3 relatime,errors=remount-ro,usrquota,grpquota 0 1
    # /dev/sda5
    UUID=d8e1f66c-1442-423e-b442-8ae66eded9d7 none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0


    This is the content of the fstab file on my computer after I added usrquota,grpquota.

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/mapper/server1-root
    UUID=04a0647e-e9c4-4f38-94e7-4d46f77e37d6 / ext3 relatime,errors=remount-ro,usrquota,grpquota 0 1
    # /dev/sdb1
    UUID=99171d62-684e-4ae5-8cbc-eae6b92e5a57 /boot ext3 relatime 0 2
    # /dev/mapper/server1-swap_1
    UUID=d549d135-5a67-46f1-82f5-e0c5392b9f1f none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

    --------------------------------------------------------------------------------------------------
    This is what's happening when I run:
    root@server1:/home/albert# quotacheck -avugm

    quotacheck: WARNING - Quotafile //quota.user was probably truncated. Cannot save quota settings...
    quotacheck: WARNING - Quotafile //quota.group was probably truncated. Cannot save quota settings...
    quotacheck: Scanning /dev/mapper/server1-root [/] quotacheck: Something weird happened while scanning. Error 2133571361
    root@server1:/home/albert#
     
  6. falko

    falko Super Moderator ISPConfig Developer

    This is normal when you run quotacheck for the first time.


    Any errors in your logs? What's the output of
    Code:
    mount
    ?
     
  7. Al1937

    Al1937 New Member

    I install 9.04 3 times , 8.04 twice.
    I just did a reinstall for 9.04 . The only thing I did different was to use only 20 gb instead of full 40.7 gb when installing system. I swear I had the same quota problems with the preceding installs but this time IT WORKED. I apologize for wasting your time with this, I have no explanation as to what was happening. But many thanks for your patience and help.
    Al
    No more Quota problems, it is fixed and I don't know how.
     

Share This Page