quotacheck error message

Discussion in 'Installation/Configuration' started by HobsonDrake, Jan 30, 2010.

  1. HobsonDrake

    HobsonDrake New Member

    I am following the howto for Fedora server. After following the steps for quota I run the
    quotacheck -avugm and get these errors.

    quotacheck: WARNING - Quotafile //aquota.user was probably truncated. Cannot save quota settings...
    quotacheck: WARNING - Quotafile //aquota.group was probably truncated. Cannot save quota settings...
    quotacheck: Scanning /dev/mapper/vg_doghouse-lv_root [/] quotacheck: lstat Cannot stat `//home/John/.gvfs': Permission denied
    Guess you'd better run fsck first !
    exiting...

    I have rechecked the fstab and recreated the /aquota.user and /aquota.group.

    I also did and ls -al on the //home/John/.gvfs and it has a permissions of
    d????????? ? ? ? ? .gvfs

    Any ideas what is going on?
    Thanks, John
     
  2. HobsonDrake

    HobsonDrake New Member

    OK some more info and questions on this.
    I followed the Howto for Fedora 12. I was looking at the Howto for Fedora 11 and there are some differences.
    In the fstab for 12 it says to add after defaults ,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0
    and in 11 it says to add ,usrquota,grpquota

    Let me add that my system is not 64bit

    and here is my fstab just in case some one needs to see it

    # /etc/fstab
    # Created by anaconda on Tue Jan 26 12:13:28 2010
    #
    # Accessible filesystems, by reference, are maintained under '/dev/disk'
    # See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
    #
    /dev/mapper/vg_doghouse-lv_root / ext4 defaults,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 1 1
    UUID=de1b8e93-1d57-42af-a39a-ee5a200a869f /boot ext4 defaults 1 2
    /dev/mapper/vg_doghouse-lv_swap swap swap defaults 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    sysfs /sys sysfs defaults 0 0
    proc /proc proc defaults 0 0
     
  3. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    The Fedora 12 tutorial uses journaled quota - does it work with that?
     
  4. HobsonDrake

    HobsonDrake New Member

    falko, I am unfamiliar with quota. So I don't know the difference between that and journaled quota. What would the request be? Can you tell me what to look for please. I will look it up with #man.
    Thanks.
    John
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Which instructions gave you the error? The instructions from the Fedora 12 or the Fedora 11 tutorial?
     
  6. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

    @Falko,
    Also on Debian Lenny, now a message occurs, which suggests to use journaled quota instead.
    I ignored it during installation, but i want you to know.
     
  7. HobsonDrake

    HobsonDrake New Member

    The instruction was
    quotacheck -avugm

    Taken from page 3 of
    The Perfect Server - Fedora 12 x86_64 [ISPConfig 2]
     
  8. melask

    melask New Member

    Ok.

    First of all Hi,

    I saw ur issue here...and registered only to reply you xexe :)

    I am using Ubuntu 9.10 and i had exactly tha same problem. So a possible solution is: to run the commands through a tty window and not through kde or gnome's terminal console window.

    Just log off from your graphical environment and switch to e.g. tty1 window with the ctrl+alt+F1 keys. Run all the commands there (after u login ofc) and u are ok.

    Switch back to kde/gnome with ctrl+alt+F7

    Hope, I helped ya.
     
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Ok, can you try the instructions from the Fedora 11 tutorial? Do these work?
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Hi Hans,

    yes, I know, but these are just warnings. If you want to set up journaled quota, take a look here: http://www.howtoforge.com/how-to-set-up-journaled-quota-on-debian-lenny :)
     
  11. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

  12. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I *think* that should work. You might have to delete the current /aquota.user and /aquota.group files though.
     
  13. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

    Now, i've setup journaled quota on my ISPConfig3 servers according your howto and it's working fine. :)
     
  14. cyberw

    cyberw New Member

    Did the original poster get a result?

    I am having the same permission denied problem when running the quotacheck command from the FC12 tutorial. FC12 ISPConfig3.

    Cyberw
     
  15. herbie

    herbie New Member

    and also I from the Ubuntu 10.04 install... the switching to tty didn't work either, same error message.
    But rebooting the system and they trying again shows quotas are ON...
    need to re-read fstab first?
     
    Last edited: Aug 7, 2010
  16. muhaemin

    muhaemin New Member

    my solution

    1. from desktop manager (i.e. kde, etc.) pres Ctrl+Alt+F1
    2. login as root on terminal
    3. $ /etc/init.d/lightdm stop
    4. quotacheck -avugm
     
  17. herbie

    herbie New Member

    I forgot about this thread...
    everything sets up upon reboot. I've done several more setups and just rebooted after the quota setup before continuing on.
     

Share This Page