quotacheck: Cannot find filesystem to check

Discussion in 'Installation/Configuration' started by xetic, Aug 11, 2008.

  1. orasis

    orasis Member

    I installed ubuntu 9.04 desktop-i386 and followed the steps of "The Perfect Server - Ubuntu 9.04 [ISPConfig 3]"

    I am stuck at the same point with the
    Code:
    quotacheck -avugm
    ..command returning

    Code:
    quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.
    my fstab looks like this:
    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'vol_id --uuid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # / was on /dev/sda3 during installation
    UUID=5f5c3e99-140d-4e6e-8aed-ace072858abb /               ext4    relatime,errors=remount-ro,usrquota,grpquota 0       1
    
    
    # swap was on /dev/sda5 during installation
    UUID=f40b0fdc-60c1-4cd3-a481-a9dd4e6ce563 none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
    I have tried reboot with no luck. also tried changing this line:
    Code:
    UUID=5f5c3e99-140d-4e6e-8aed-ace072858abb /               ext4    relatime,errors=remount-ro,usrquota,grpquota 0       1
    to this:
    Code:
    /dev/sda3 /               ext4    relatime,errors=remount-ro,usrquota,grpquota 0       1
    no luck either. i also tried (as many said) retyping the whole line by hand, or using
    Code:
    quotacheck -acvugm
    insteed of
    Code:
    quotacheck -avugm
    Is it a mater of ext4 maybe ? although the setup is for ubuntu server and not for ubuntu desktop, I have setup ispconfig in the past with no errors on previous ubuntu releases. so by the way is that any problem ?

    I will try to reinstall ubuntu using ext3 and try the steps again to see what happens while waiting for an advice maybe.

    thanks
     
    Last edited: May 11, 2009
  2. orasis

    orasis Member

    back I am, ok this time I got this:

    quotacheck -avugm
    Code:
    quotacheck: Your kernel probably supports journaled quota but you are not using it. Consider switching to journaled quota to avoid running quotacheck after an unclean shutdown.
    quotacheck: WARNING - Quotafile //quota.user was probably truncated. Cannot save quota settings...
    quotacheck: WARNING - Quotafile //quota.group was probably truncated. Cannot save quota settings...
    quotacheck: Scanning /dev/sda3 [/] done
    quotacheck: Checked 13522 directories and 111120 files
    
    quotaon -avug
    Code:
    /dev/sda3 [/]: group quotas turned on
    /dev/sda3 [/]: user quotas turned on
    
    looks like it worked for me.. got no idea if it was ext4 problem but it feels like that.
    best wishes guys with this amazing work you do, I go to continue installation :)
     
  3. orasis

    orasis Member

    PERFECT !!!

    congratulations
    best wishes
     
  4. maumar

    maumar Member HowtoForge Supporter

    iI have had the same issue, to solve it i needed to put selinux into disabld mode.
    Putting selinux in permissive mode is not enough
    quotacheck should be done before quoataon
     

Share This Page