Quota

Discussion in 'Installation/Configuration' started by Th0m, Jan 2, 2020.

  1. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    I mounted an extra partition on my Debian 10 installation to place the mail and www data on. I'm trying to enable quota for it, but I can't get it to work.

    /etc/fstab:
    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    # / was on /dev/sda1 during installation
    UUID=d1f30f2e-a56f-40fa-b1a5-8f5cd466f04c /               ext4    errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0       1
    /dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
    #ISPConfig logs:
    /var/log/ispconfig/httpd/DOMAIN /mnt/volume-nbg1-1/www/clients/client0/web1/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /mnt/volume-nbg1-1/www/clients/client0/web2/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /mnt/volume-nbg1-1/www/clients/client1/web3/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /mnt/volume-nbg1-1/www/clients/client0/web4/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /mnt/volume-nbg1-1/www/clients/client2/web6/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /mnt/volume-nbg1-1/www/clients/client2/web7/log    none    bind,nobootwait    0 0
    
    # Schijf 2:
    /dev/disk/by-id/scsi-0HC_Volume_3692680 /mnt/volume-nbg1-1 ext4 discard,nofail,defaults 0 0
    
    # Verplaatsing van www en vmail naar volume-X
    /mnt/volume-X/vmail /var/vmail none bind,nobootwait,_netdev 0 0
    /mnt/volume-X/www /var/www none bind,nobootwait,_netdev 0 0
    
    # Hier gaat ISPConfig weer verder met zijn logs:
    /var/log/ispconfig/httpd/DOMAIN /var/www/clients/client3/web4/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /var/www/clients/client3/web4/log    none    bind,nofail    0 0
    /var/log/ispconfig/httpd/DOMAIN/var/www/clients/client3/web11/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /var/www/clients/client3/web12/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /var/www/clients/client2/web14/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /var/www/clients/client3/web15/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /var/www/clients/client2/web16/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /var/www/clients/client3/web24/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /var/www/clients/client3/web30/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/DOMAIN /var/www/clients/client5/web38/log    none    bind,nobootwait    0 0
    I tried adding
    Code:
    errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0
    , like this:
    Code:
    /dev/disk/by-id/scsi-0HC_Volume_3692680 /mnt/volume-nbg1-1 ext4 errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 discard,nofail,defaults 0 0
    But when remounting, it gives an error for that line. How do I set this up correctly?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What is that error?
    Code:
    jqfmt=vfsv0 discard,nofail
    Is there a space character in the middle of the options string? That is one error at least.
     
  3. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    Thanks, oversaw that! It's working now.
     

Share This Page