quota with different partitions/drives

Discussion in 'Installation/Configuration' started by ustoopia, Aug 8, 2007.

  1. ustoopia

    ustoopia New Member

    Hi everybody

    I installed ispconfig on a debian etch server that has two hard drives. swap and / are located on the first drive (hda) On the second drive (hdb) I mounted two partitions as /home and /var. Since all the websites will be places in /var/www I was wondering how I should setup the quota. I already setup qouta for /, but since /var is located on a different partition on a complete other drive I was wondering if I should also enable quota for those partitions.

    Here is what my /etc/fstab looks like now

    Code:
    /dev/hda2       /               ext3	defaults,errors=remount-ro,usrquota,grpquota 0       1
    /dev/hdb2       /home           ext3    defaults        0       2
    /dev/hdb1       /var            ext3    defaults        0       2
    /dev/hda1       none            swap    sw              0       0
    Before I go ahead and do what I think has to be done I thought I post a message here or else I might **** things up again.
    I believe I will have to add ,usrquota,grpquota to the /var partition is that correct? Here's what I believe it should look like. Please correct me if I'm wrong...

    Code:
    /dev/hda2       /               ext3	defaults,errors=remount-ro,usrquota,grpquota 0       1
    /dev/hdb2       /home           ext3    defaults        0       2
    /dev/hdb1       /var            ext3    defaults,usrquota,grpquota        0       2
    /dev/hda1       none            swap    sw              0       0
    Any reply will be greatly appreciated
    Keep up the good work ;-)
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, the second config looks fine. Quota must be anebled for /var too.
     
  3. lubos

    lubos New Member HowtoForge Supporter

    quota?

    Hi Till, please can you check following:

    this are my partitions on two servers and what i believe it should look like.

    Server1
    Note: partition /var/www is mounted by s-link onto /www and chmoded to 775 to make sure that it can be accessible ;)

    Code:
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/hda1       /               ext3    defaults,errors=remount-ro,usrquota,grpquota 0       1
    /dev/hda9       /home           ext3    defaults        0       2
    /dev/hda7       /tmp            ext3    defaults        0       2
    /dev/hda5       /usr            ext3    defaults        0       2
    /dev/hda6       /var            ext3    defaults,usrquota,grpquota        0       2
    /dev/hda3       /www            ext3    defaults,usrquota,grpquota        0       2
    /dev/hda8       none            swap    sw              0       0
    /dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
    
    and second:

    Code:
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/hda1       /               ext3    defaults,errors=remount-ro,usrquota,grpquota 0       1
    /dev/hda7       /home           ext3    defaults        0       2
    /dev/hdb1       /mail_backup    ext3    defaults        0       2
    /dev/hda6       /tmp            ext3    defaults        0       2
    /dev/hda5       /usr            ext3    defaults        0       2
    /dev/hda3       /var            ext3    defaults,usrquota,grpquota        0       2
    /dev/hdb3       /www-backup     ext3    defaults        0       2
    /dev/hda8       none            swap    sw              0       0
    /dev/hdb2       none            swap    sw              0       0
    /dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
    
    I am pretty sure that this is right :cool:... but I started on Linux only in October 2007..:eek:

    Thanx upfront.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. :)
     
  5. hardly

    hardly New Member

    errors and unsettling output.

    I'm trying to enable quota for multiple partitions.
    The quota.user and quota.group files should be placed on partitions other than / if you want to enable quota for them, correct? That is aside from adding the ',usrquota,grpquota' bit to those lines in /etc/fstab.

    I'm receiving weird output.

    Code:
    # vim /etc/fstab
    # touch /quota.user /quota.group /var/quota.user /var/quota.group /home/quota.user /home/quota.group
    # chmod 600 /quota.*
    # mount -o remount /
    # chmod 600 /home/quota.*
    # mount -o remount /home
    # chmod 600 /var/quota.*
    # mount -o remount /var
    # quotacheck -avugm
    quotacheck: Your kernel probably supports journaled quota but you are not using it. Consider switching to journaled quota to avoid running quotacheck after an unclean shutdown.
    quotacheck: WARNING - Quotafile /var/quota.user was probably truncated. Cannot save quota settings...
    quotacheck: WARNING - Quotafile /var/quota.group was probably truncated. Cannot save quota settings...
    quotacheck: Scanning /dev/sda4 [/var] done
    quotacheck: Checked 144 directories and 2812 files
    Shouldn't there be something like the "Scannig /dev/sda4 [/var] done" for the other two partitions I'm trying to use quota on?

    Interesting lines in /etc/fstab
    Code:
    proc            /proc           proc    defaults        0       0
    UUID=673e37c2-f61e-4f36-b63d-08cab35a703a /               ext4    relatime,errors=remount-ro,usrquota,grpquota 0       1
    UUID=3eb8e733-527a-4c9e-b468-122ec877cba8 /home           ext4    relatime,usrquota,grpquota        0       2
    UUID=c86361ff-f9f8-4921-a4f6-2769f579ef23 /tmp            ext3    relatime        0       2
    UUID=601b8582-5aed-4efb-8efe-3de3bd411832 /usr            ext3    relatime        0       2
    UUID=5b1f7704-a03b-4d9b-b29a-721de8e149ba /var            ext3    relatime,usrquota,grpquota        0       2
    UUID=1fcb9e95-acac-445e-a733-53291d727874 none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    Is there something that I'm missing?

    [Also]
    Code:
    # quotaon -avug
    /dev/sda4 [/var]: group quotas turned on
    /dev/sda4 [/var]: user quotas turned on
    with no mention of / or /home.
    ==============================================================
    I've decided to go ahead and put /home/me on my own partition and only use 1 partition for everything else in /. THat is way simpler and is really what I was going for.
    Still though, why was I getting those results, if anyone is willing to subject me to their thoughts on the matter. :D
    =========================================================================================
    'nother edit.

    I'm using ext4. before, /var was on ext3, but / and /home were ext4. That's the problem. And I'm having way too much trouble with 64bit ubuntu server. So I guess I'll be starting over with the lowest common denomerator. <-- yeah, I'm just gonna leave it that way. lol
     
    Last edited: Jul 20, 2009

Share This Page