Quota/used space shows up unlimited after added HDD and moved web folder

Discussion in 'Installation/Configuration' started by Icey, Nov 19, 2017.

  1. Icey

    Icey New Member

    Debian 8.7 running ISPConfig 3.1.8
    Quota and used space shows up unlimited after added HDD and moved web folder.

    I Added a second HDD flowing the thread here: https://www.howtoforge.com/community/threads/add-second-hdd-ispconfig-3-debian-7.68862/
    And then moved the web and backup location flowing the guide here: https://www.howtoforge.com/use_moun...ctory_of_a_ispconfig_server_to_a_new_location

    In the top of fstab:
    Code:
    # /etc/fstab: static file system information.
    proc    /proc   proc    nodev,noexec,nosuid     0       0
    /dev/vda1       /       ext3    errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0      0       1
    /dev/vdb       /diskb/   ext4   errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0      0       2
    /diskb/www /var/www none bind,nobootwait,_netdev 0 0
    /diskb/backup /var/backup none bind,nobootwait,_netdev 0 0
    
    I've tried updating ISPConfig from 3.1.6 to 3.1.8 and it did not work.

    Can someone help me get the quota to work again?
     
  2. ahrasis

    ahrasis Active Member

    I don't see quota added to /diskb/www which I assume you are using for your web folder.
     
  3. Icey

    Icey New Member

    Ok, sounds like we might have a solution then.

    What would be the correct form of doing this? I'm not good on understanding fstab.
    Edit: I thought since I have it on: /dev/vdb /diskb/ and the web and backup directory is inside that disk it would effect them as well?
     
    Last edited: Nov 20, 2017
  4. ahrasis

    ahrasis Active Member

    I am not sure myself as I am using Ubuntu with UUID instead of directory. Basically, each line of UUID refer to different partition. So, my guess is yours could have the same idea.
     
  5. Icey

    Icey New Member

    Ok @ahrasis did not help me much. :(
    Someone else got an idea? I guess this have happened to lots of people following the guide I linked to?
     
  6. Jesse Norell

    Jesse Norell Well-Known Member

    For quotas to work you both need them setup in the filesystem (eg. 'repquota /dev/vdb' should show at least some quota entries), you need the fstab to have quota options for the device (/dev/vdb does have some options, and I'd guess they do not need added for the /diskb/www bind mount, so it may be correct), and you need to have quotas set for your users, which ISPconfig will do when you add new users, but you may need to resync (or add them manually?) for existing users to have quotas set if you add a new disk. What do 'repquota /dev/vdb' and 'repquota /diskb/www' show?
     
  7. Icey

    Icey New Member

    Thank's for your answer! Below you can see the answers on the command and how my fstab is set up now.

    How do I resync?

    Code:
    repquota /dev/vdb
    repquota: Cannot open quotafile /diskb/aquota.user: No such file or directory
    repquota: Not all specified mountpoints are using quota.
    
    Code:
    repquota /diskb/www
    repquota: Mountpoint (or device) /diskb/www not found or has no quota enabled.
    repquota: Not all specified mountpoints are using quota.
    
    Code:
    # /etc/fstab: static file system information.
    proc    /proc   proc    nodev,noexec,nosuid     0       0
    /dev/vda1       /               ext3    errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0              0       1
    /dev/vdb        /diskb/         ext4    errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0              0       2
    /diskb/www      /var/www        none    bind,nobootwait,_netdev,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0        0       0
    /diskb/backup   /var/backup     none    bind,nobootwait,_netdev 0 0
    
     
  8. Jesse Norell

    Jesse Norell Well-Known Member

  9. Icey

    Icey New Member

    Thanks! Not solved but feel's like we are on the right way :)

    I did
    Code:
    touch /diskb/aquota.user /diskb/aquota.group
    chmod 600 /diskb/aquota.*
    mount -o remount /dev/vdb
    
    All good. But then, problem:
    Code:
    [email protected]/# quotacheck -avugm
    quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
    Please turn quotas off or use -f to force checking.
    [email protected]:/# quotacheck -avugm -f
    quotacheck: Scanning /dev/vda1 [/] done
    quotacheck: Checked 8761 directories and 124807 files
    quotacheck: WARNING -  Quotafile /diskb/aquota.user was probably truncated. Cannot save quota settings...
    quotacheck: WARNING -  Quotafile /diskb/aquota.group was probably truncated. Cannot save quota settings...
    
    Edit: This got me half way: http://forums.debian.net/viewtopic.php?f=5&t=59985 Now I can see the space used per site. But I can not se the soft and hard limits. They are still unlimited.

    Tried to reset one site to new value, had no effect. No effect creating a new site either and setting a limit on it.

    Edit 2: It worked! Just took a while. Now the site I set have a limit and looks good. So just have to go through all sites and set limits.

    Thanks for all the help peeps! :)
     
    Last edited: Nov 21, 2017
    ahrasis likes this.

Share This Page