Quota setup in Perfect Debian Sarge

Discussion in 'HOWTO-Related Questions' started by chris_87, Dec 26, 2005.

  1. chris_87

    chris_87 New Member

    Hi,

    Another error I faced today, when I try to setup the quota, I've got a message
    quotacheck: Scanning /dev/hda1 [/] Cannot get exact used space... Results might be inaccurate.
    done
    quotacheck: Checked 1211 directories and 13578 files

    when I perform quotacheck -avugm.

    Any Ideas?

    Thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

    That's just a warning. If
    Code:
    quotaon -avug
    says that quota is turned on then everything is fine.
     
  3. chris_87

    chris_87 New Member

    No luck still.:confused:
    quotaon -avug
    quotaon: Cannot find quota file on / [/dev/hda1] to turn quotas on/off.
    quotaon: Cannot find quota file on / [/dev/hda1] to turn quotas on/off.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    ls -la /
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Did you do this:
    Code:
    touch /quota.user /quota.group
    chmod 600 /quota.*
    mount -o remount /
    quotacheck -avugm
    quotaon -avug
    as described on http://www.howtoforge.com/perfect_setup_debian_sarge_p3?
     
  6. chris_87

    chris_87 New Member

    yes...I do the exactly..
    just copy and paste
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Chris, can you please post the output of:

    Code:
    ls -la /
     
  8. chris_87

    chris_87 New Member

    total 38565
    drwxr-xr-x 21 root root 4096 Dec 27 15:43 .
    drwxr-xr-x 21 root root 4096 Dec 27 15:43 ..
    drwxr-xr-x 2 root root 4096 Dec 28 02:37 bin
    drwxr-xr-x 2 root root 4096 Apr 25 2004 boot
    drwxr-xr-x 2 root root 4096 Apr 25 2004 cdrom
    -rw-r----- 1 root root 39301055 Dec 26 17:19 debian_2005_04_09_dist.tgz
    drwxr-xr-x 4 root root 20480 Dec 27 17:58 dev
    drwxr-xr-x 64 root root 4096 Dec 28 02:55 etc
    drwxr-xr-x 2 root root 4096 Apr 25 2004 floppy
    drwxrwsr-x 8 root staff 4096 Dec 27 00:21 home
    drwxr-xr-x 16 root root 1024 Oct 14 2004 initrd
    drwxr-xr-x 5 root root 4096 Dec 26 18:36 lib
    drwxr-xr-x 2 root root 4096 May 2 2004 lost+found
    drwxr-xr-x 2 root root 4096 May 2 2004 mnt
    drwxr-xr-x 2 root root 4096 Apr 25 2004 opt
    dr-xr-xr-x 87 root root 0 Dec 27 17:58 proc
    -rw------- 1 root root 2097120 Dec 27 15:43 quota.group
    -rw------- 1 root root 2097120 Dec 27 15:43 quota.user
    drwxr-xr-x 2 root root 4096 Dec 26 19:12 root
    drwxr-xr-x 2 root root 4096 Dec 26 18:36 sbin
    drwxr-xr-x 2 root root 4096 May 10 2005 sys
    drwxrwxrwt 4 root root 4096 Dec 28 12:47 tmp
    drwxr-xr-x 13 root root 4096 Dec 26 21:20 usr
    drwxr-xr-x 14 root root 4096 Dec 26 18:03 var

    Any Idea?
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Please try this:
    Code:
    rm -f /quota.user
    rm -f /quota.group
    touch /[B][COLOR="Red"]a[/COLOR][/B]quota.user /[B][COLOR="Red"]a[/COLOR][/B]quota.group
    chmod 600 /[B][COLOR="Red"]a[/COLOR][/B]quota.*
    mount -o remount /
    quotacheck -avugm
    quotaon -avug
     
  10. chris_87

    chris_87 New Member

    Code:
    
    Still no luck..
    vchow:~# rm -f /quota.user
    vchow:~# rm -f /quota.group
    vchow:~# touch /aquota.user /aquota.group
    vchow:~# chmod 600 /aquota.*
    vchow:~# mount -o remount /
    vchow:~# quotacheck -avugm
    quotacheck: WARNING -  Quotafile //aquota.user was probably truncated. Can't sav                                              e quota settings...
    quotacheck: WARNING -  Quotafile //aquota.group was probably truncated. Can't sa                                              ve quota settings...
    quotacheck: Scanning /dev/hda1 [/] Cannot get exact used space... Results might                                               be inaccurate.
    done
    quotacheck: Checked 5456 directories and 32248 files
    vchow:~# quotaon -avug
    quotaon: Cannot find quota file on / [/dev/hda1] to turn quotas on/off.
    quotaon: Cannot find quota file on / [/dev/hda1] to turn quotas on/off.
    
    
    drwxr-xr-x  21 root root   4096 Dec 29 01:17 .
    drwxr-xr-x  21 root root   4096 Dec 29 01:17 ..
    -rw-------   1 root root  11264 Dec 29 01:13 aquota.group
    -rw-------   1 root root  10240 Dec 29 01:13 aquota.user
    drwxr-xr-x   2 root root   4096 Dec 28 02:37 bin
    drwxr-xr-x   2 root root   4096 Apr 25  2004 boot
    drwxr-xr-x   2 root root   4096 Apr 25  2004 cdrom
    drwxr-xr-x   4 root root  20480 Dec 29 00:48 dev
    drwxr-xr-x  64 root root   4096 Dec 29 01:12 etc
    drwxr-xr-x   2 root root   4096 Apr 25  2004 floppy
    drwxrwsr-x   8 root staff  4096 Dec 27 00:21 home
    drwxr-xr-x  16 root root   1024 Oct 14  2004 initrd
    drwxr-xr-x   5 root root   4096 Dec 26 18:36 lib
    drwxr-xr-x   2 root root   4096 May  2  2004 lost+found
    drwxr-xr-x   2 root root   4096 May  2  2004 mnt
    drwxr-xr-x   2 root root   4096 Apr 25  2004 opt
    dr-xr-xr-x  86 root root      0 Dec 29 00:42 proc
    drwxr-xr-x   2 root root   4096 Dec 26 19:12 root
    drwxr-xr-x   2 root root   4096 Dec 26 18:36 sbin
    drwxr-xr-x   2 root root   4096 May 10  2005 sys
    drwxrwxrwt   4 root root   4096 Dec 29 00:48 tmp
    drwxr-xr-x  13 root root   4096 Dec 26 21:20 usr
    drwxr-xr-x  14 root root   4096 Dec 26 18:03 var
    
    
    Can anyone help me:confused:
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you execute the above steps as root user?
     
  12. chris_87

    chris_87 New Member

    yes, I do..all execute under root access
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Can you post your /etc/fstab here?
     
  14. chris_87

    chris_87 New Member

    Here you go

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    /dev/hda1 / ext3 defaults,errors=remount-ro,usrquota,grpquota 0 1
    proc /proc proc defaults 0 0
    none /dev/pts devpts gid=5,mode=20 0 0
    /dev/hda2 swap swap defaults 0 0
    /dev/hda3 /mnt ext3 defaults,noatime 0 0
    ~
     
  15. falko

    falko Super Moderator ISPConfig Developer

    Maybe this happens because of the "remount-read-only" option in your /etc/fstab...
    Have you also tried to reboot the whole system instead of remounting the partition?
     
  16. mccharlet

    mccharlet Member HowtoForge Supporter

    Hi,

    I have the same problem.

    # quotacheck -avugm
    quotacheck: WARNING - Quotafile //quota.user was probably truncated. Can't save quota settings...
    quotacheck: WARNING - Quotafile //quota.group was probably truncated. Can't save quota settings...
    quotacheck: Scanning /dev/hda2 [/] quotacheck: error (6) while opening /dev/hda2
    # quotaon -avug
    quotaon: Cannot find quota file on / [/dev/hda2] to turn quotas on/off.
    quotaon: Cannot find quota file on / [/dev/hda2] to turn quotas on/off.


    Are you find a solution

    Tanks
    C├ędric
     
    Last edited: Feb 27, 2007
  17. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use?
     
  18. mccharlet

    mccharlet Member HowtoForge Supporter

    Hi

    I have a virtual server with debian 3.1 kernel 2.6
     
  19. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/fstab, and what's the output of
    Code:
    fdisk -l
    ?
     
  20. mccharlet

    mccharlet Member HowtoForge Supporter

    File fstab

    # /etc/fstab: static file system information.
    #
    #<file sys> <mount point> <type> <options> <dump> <pass>
    /dev/hda2 / ext3 defaults,errors=remount-ro,usrquota,grpquota 0 1
    /swapfile none swap rw 0 0
    none /proc proc defaults 0 0

    fdisk -l nothing display :confused:
     

Share This Page