quota problem

Discussion in 'HOWTO-Related Questions' started by abyss, Aug 21, 2007.

  1. abyss

    abyss New Member

    Hello All,

    I recently own a vps machine and install debian 4.0 etch on it. I'd follow up exactly the
    http://www.howtoforge.com/virtual_users_and_domains_with_postfix_debian_etch
    guide except the part with amavis/spamassasin etc cause i have limited resources at my vps. All the other things are working fine. except the quota. I follow exactly the guide for adding the patch to the postfix and the quide for the quota.txt file. but i'm getting a summary email for only 2 users, even that i have users that they are over quota's. Cause i'm rookie:eek: with this stuff, i need your help:p

    p.s. (sorry for any mistakes , i'm not a native english speaker
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your logs?
     
  3. abyss

    abyss New Member

    no.. i didn't see anything.. strange... ? any ideas..? something to look for..?
    all seems to be normal
     
  4. abyss

    abyss New Member

    i dont know if it helps.. I took a closer look to mysql log..

    070823 2:38:36 115 Connect [email protected] on mail
    115 Query SELECT transport FROM transport WHERE domain='*'
    115 Query SELECT transport FROM transport WHERE domain='*'
    116 Connect [email protected] on mail
    116 Query SELECT destination FROM forwardings WHERE source='[email protected]'
    117 Connect [email protected] on mail
    117 Query SELECT email FROM users WHERE email='[email protected]'
    118 Connect [email protected] on mail
    118 Query SELECT CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/') FROM users WHERE email='[email protected]'

    this is the part when the quota_notify runs.

    and this is the beginng of the quota_notify from where i changes the variables at the begining adn i put the admin email and the domain.. did i made something wrong?

    my $POSTFIX_CF = "/etc/postfix/main.cf";
    my $MAILPROG = "/usr/sbin/sendmail -t";
    my $WARNPERCENT = 80;
    my @POSTMASTERS = ('[email protected]');
    my $CONAME = 'domain.ltd';
    my $COADDR = '[email protected]';
    my $SUADDR = '[email protected]';
    my $MAIL_REPORT = 1;
    my $MAIL_WARNING = 1;


    hope those will help a bit..:(
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Seems to be ok... :confused:
     
  6. abyss

    abyss New Member

    yes i also can not understand . i take 2 notify's user root and user admin . i dont know what is wrong. Maybe the part that 117 Query SELECT email FROM users WHERE email='[email protected]' must me something like 'domain.ltd' or * ..?

    anyone else that use this quide..? is the quota stuff working ok..?
     
  7. falko

    falko Super Moderator ISPConfig Developer

    It's working for me...
     
  8. abyss

    abyss New Member

    so... i have to think that i will not have quota check:) this is something not important for this moment.. the think that i'm worried about, is that i dont know what to look for.. , i'll try to setup again in other pc to discover something maybe..
     

Share This Page