Quota problem in tutorial article.

Discussion in 'Installation/Configuration' started by vaio1, Feb 17, 2011.

  1. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    Hi Falko and Till,

    I have found a problem within this article about the Quota setup: Installing A Multiserver Setup With Dedicated Web, Email, DNS And MySQL Database Servers On Debian 5.0 With ISPConfig 3

    Code:
    To enable quota, run these commands:
    
    touch /quota.user /quota.group
    chmod 600 /quota.*
    mount -o remount /
    
    quotacheck -avugm
    quotaon -avug
    
    This is the result in my box:
    Code:
    root@webserver:/# touch /quota.user /quota.group
    root@webserver:/# chmod 600 /quota.*
    root@webserver:/# mount -o remount /
    root@webserver:/# 
    root@webserver:/# quotacheck -avugm
    quotacheck: Your kernel probably supports journaled quota but you are not using it. Consider switching to journaled quota to avoid running quotacheck after an unclean shutdown.
    quotacheck: WARNING - Quotafile //quota.user was probably truncated. Cannot save quota settings...
    quotacheck: WARNING - Quotafile //quota.group was probably truncated. Cannot save quota settings...
    quotacheck: Scanning /dev/disk/by-uuid/5376739d-9145-48f8-bf8a-f583671aea20 [/] done
    quotacheck: Checked 3897 directories and 43819 files
    root@webserver:/# quotaon -avug
    quotaon: cannot find //aquota.group on /dev/disk/by-uuid/5376739d-9145-48f8-bf8a-f583671aea20 [/]
    quotaon: cannot find //aquota.user on /dev/disk/by-uuid/5376739d-9145-48f8-bf8a-f583671aea20 [/]
    root@webserver:/# ls -la
    total 108
    drwxr-xr-x  21 root root  4096 Feb 17 08:50 .
    drwxr-xr-x  21 root root  4096 Feb 17 08:50 ..
    drwxr-xr-x   2 root root  4096 Feb 16 18:13 bin
    drwxr-xr-x   3 root root  4096 Feb 16 16:01 boot
    drwxr-xr-x  14 root root  3120 Feb 17 08:26 dev
    drwxr-xr-x  89 root root  4096 Feb 17 08:48 etc
    drwxr-xr-x   3 root root  4096 Feb 17 08:42 home
    lrwxrwxrwx   1 root root    28 Feb 16 15:51 initrd.img -> boot/initrd.img-2.6.32-5-686
    drwxr-xr-x  12 root root 12288 Feb 16 22:40 lib
    drwx------   2 root root 16384 Feb 16 15:48 lost+found
    drwxr-xr-x   3 root root  4096 Feb 16 15:49 media
    drwxr-xr-x   2 root root  4096 Dec 14 22:54 mnt
    drwxr-xr-x   2 root root  4096 Feb 16 15:50 opt
    dr-xr-xr-x 118 root root     0 Feb 17 08:26 proc
    -rw-------   1 root root 32128 Feb 17 08:50 quota.group
    -rw-------   1 root root 32096 Feb 17 08:50 quota.user
    drwx------   3 root root  4096 Feb 16 17:12 root
    drwxr-xr-x   2 root root  4096 Feb 16 22:50 sbin
    drwxr-xr-x   2 root root  4096 Jul 21  2010 selinux
    drwxr-xr-x   2 root root  4096 Feb 16 15:50 srv
    drwxr-xr-x  12 root root     0 Feb 17 08:26 sys
    drwxrwxrwt   4 root root  4096 Feb 17 08:51 tmp
    drwxr-xr-x  11 root root  4096 Feb 16 22:40 usr
    drwxr-xr-x  15 root root  4096 Feb 17 00:30 var
    lrwxrwxrwx   1 root root    25 Feb 16 15:51 vmlinuz -> boot/vmlinuz-2.6.32-5-686
    root@webserver:/# 
    
    FSTAB

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # / was on /dev/sdd5 during installation
    UUID=5376739d-9145-48f8-bf8a-f583671aea20 /               ext3    defaults,usrquota,grpquota 0       1
    # swap was on /dev/sdd6 during installation
    UUID=58b50c12-fadf-41af-aea6-be2cdfe257c2 none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
    
    What have I do?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Your kernel seems to use journaled quota. Please try this commands instead:

     

Share This Page