Quota postfix bug

Discussion in 'General' started by andypl, Apr 17, 2009.

  1. andypl

    andypl Member

    Something led me to check the quote with postfix and proves to be a problem with the size of the maildrop in quote MySQL database.

    Set the size of 2M account and sent you some big file.
    In the postfix log I have this:

    status = deferred (temporary failure. Command output: WARN: quota string'2097152 'not parseable maildrop: maildir over quota.)

    The problem is in this database.
    Quota is store in INT should be a VARCHAR, and this value should be 2097152 instead 2097152S
     
    Last edited: Apr 17, 2009
  2. till

    till Super Moderator

    Take a look at the config files that ispconfig uses, the S is concatenated automatically in the sql query and shall not be in the database, so the int value is absolutely correct as it should be.
     
  3. andypl

    andypl Member

    But the error is in the logs:

    status = deferred (temporary failure. Command output: WARN: quota string '2097152' not parseable maildrop: maildir over quota.)

    If you would value of S in a maildrop is sent by mail with the information correctly.
    Maildrop need to correct parameter checking quota.
     
  4. till

    till Super Moderator

    Pleaseake a look at your courier config files, maybe the concat part is missing there in your setup.
     
  5. andypl

    andypl Member

    this is my config

    authmysqlrc:

    MYSQL_SERVER localhost
    MYSQL_USERNAME ispconfig
    MYSQL_PASSWORD xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    MYSQL_PORT 0
    MYSQL_DATABASE dbispconfig
    MYSQL_USER_TABLE mail_user
    MYSQL_CRYPT_PWFIELD password
    #MYSQL_CLEAR_PWFIELD password
    MYSQL_UID_FIELD uid
    MYSQL_GID_FIELD gid
    MYSQL_LOGIN_FIELD email
    MYSQL_HOME_FIELD homedir
    MYSQL_MAILDIR_FIELD maildir
    #MYSQL_NAME_FIELD
    MYSQL_QUOTA_FIELD quota
    MYSQL_QUOTA_FIELD concat(quota,'S')
    #MYSQL_WHERE_CLAUSE access='y'
    MYSQL_AUXOPTIONS_FIELD concat('disableimap=',disableimap,',disablepop3=',disablepop3)

    maildrop:

    /usr/bin/maildrop
     
  6. till

    till Super Moderator

    Please comment out the line

    MYSQL_QUOTA_FIELD quota

    so that there is only the line:

    MYSQL_QUOTA_FIELD concat(quota,'S')

    which concatenates the S to the value of the filed and then restart the courier authdaemon.
     
  7. andypl

    andypl Member

    Now works correctly.
    Thx :)
     

Share This Page