quota on ubuntu 11.10 at rackspace

Discussion in 'Kernel Questions' started by centurianii, Sep 19, 2012.

  1. centurianii

    centurianii New Member


    I tried to enable quotas on my cloud server following the "proper" way (see: www.ibm.com/developerworks/linux/library/l-lpic1-v3-104-4/index.html or http://www.ubuntugeek.com/how-to-setup-disk-quotas-in-ubuntu.html or http://www.debianadmin.com/implement-and-manage-disk-quotas-in-linux.html) but with error:
    # quotaon -avug
    quotaon: using //aquota.group on /dev/xvda1 [/]: No such process
    quotaon: Quota format not supported in kernel.
    quotaon: using //aquota.user on /dev/xvda1 [/]: No such process
    quotaon: Quota format not supported in kernel.
    After searching I found a user's answer at: www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3-p5 suggesting installation of linux-image-extra-virtual.
    After installation I saw the differences between what rackspace gave me and what I have now:

    # ls -al /lib/modules
    total 20
    drwxr-xr-x  5 root root 4096 2012-09-18 10:44 .
    drwxr-xr-x 16 root root 4096 2012-09-04 10:32 ..
    drwxr-xr-x  2 root root 4096 2011-10-18 15:49 3.0.0-12-server
    drwxr-xr-x  4 root root 4096 2011-10-20 20:47 3.0.0-12-virtual
    drwxr-xr-x  4 root root 4096 2012-09-18 10:46 3.0.0-26-virtual
    # ls -al /lib/modules/3.0.0-12-virtual/kernel/fs/
    no quota dir
    # ls -al /lib/modules/3.0.0-12-virtual/kernel/fs/
    Finally, I tried to solve ALL my problems with:
    # modprobe  /lib/modules/3.0.0-26-virtual/kernel/fs/quota/quota_v2.ko
    FATAL: Module /lib/modules/3.0.0_26_virtual/kernel/fs/quota/quota_v2.ko not found.
    or any other combination with NO result.

    What's strange? My kernel remains at 12:
    # uname -r
    Any help?
  2. centurianii

    centurianii New Member

    S O L V E D!
    1. Simply edit my /boot/grub/menu.lst and added first in list (at the end) the following:

    title Ubuntu 12.04, kernel 3.2.0-30-virtual
    root (hd0)
    kernel /boot/vmlinuz-3.2.0-30-virtual root=/dev/xvda1 console=hvc0 ro quiet splash
    initrd /boot/initrd.img-3.2.0-30-virtual

    check /boot to see actual names.

    2. Then, I rebooted and
    quotaon -uagv
    or -if errors
    modprobe quota_v2
    quotaon -uagv

    that's it!

Share This Page