Quota on second raid (not OS raid)

Discussion in 'Installation/Configuration' started by erosbk, May 26, 2011.

  1. erosbk

    erosbk New Member

    Right now, I am using a raid 1 for swap/OS (2 disks, 4 partitions.)

    For user data, I am using a different pair of disks in raid 1 mounted by fstab in /userdata.

    Do I have to add "errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0" in fstab for the data raid? and next do I have to run quotaon and the other commands? could you help me please?

    Thanks in advance.

    Edit: this is my fstab file

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # / was on /dev/md1 during installation
    UUID=be4fc8a4-33f9-4ffa-a204-33e0051d32d7 /               ext4    errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0       1
    # /tecdata was on /dev/md2 during installation
    UUID=a413be56-17c3-4262-aa2f-83a06a76d6bf /tecdata        ext4    defaults        0       2
    # /tecdatabackup was on /dev/sde1 during installation
    UUID=86998da5-58ae-4f09-bfaa-74658af88203 /tecdatabackup  ext4    defaults        0       2
    # swap was on /dev/md0 during installation
    UUID=ab8fc625-9326-469e-95c1-bee359289b57 none            swap    sw              0       0
    
     
    Last edited: May 26, 2011
  2. eko_taas

    eko_taas New Member

  3. erosbk

    erosbk New Member

    Ok, I modified fstab to:

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # / was on /dev/md1 during installation
    UUID=be4fc8a4-33f9-4ffa-a204-33e0051d32d7 /               ext4    errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0       1
    # /tecdata was on /dev/md2 during installation
    UUID=a413be56-17c3-4262-aa2f-83a06a76d6bf /tecdata        ext4    defaults[B],usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0[/B]        0       2
    # /tecdatabackup was on /dev/sde1 during installation
    UUID=86998da5-58ae-4f09-bfaa-74658af88203 /tecdatabackup  ext4    defaults        0       2
    # swap was on /dev/md0 during installation
    UUID=ab8fc625-9326-469e-95c1-bee359289b57 none            swap    sw              0       0
    
    I do not added errors=remount-ro, I just let default (do I have to change this?)

    Next, I did:

    mount -o remount /tecdata
    quotaoff -avug
    quotacheck -avugm
    quotaon -avug

    It is working right now, could you tell me if I have to add errors=remount-ro? :p

    Thanks in advance!
     
  4. eko_taas

    eko_taas New Member

    add errors=remount-ro?

    As a newbee this seems to me like an option (adviced by Gurus :) ) - if error happens on mount, remounting as read-only (nothing more, nothing less as I see it)

    I would assume that in most of the cases (like mine) above not needed (if not /) (but I pref to follow what Gurus are telling as makes my life easier :cool: )
     

Share This Page