Quota not showing in Control Panel

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Feb 26, 2020.

  1. pawan

    pawan Member HowtoForge Supporter

    I have a new ISPCONFIG3 installation, installed using - ubuntu-ispconfig-automated-install-script
    I have allocated the space for website, but in report in website quota hardisk it is showing like this:

    Code:
    web2 NAN unlimited unlimited
    web1 NAN unlimited unlimited
    also backups are not created on mount harddisk, whereas I have changed the mount point as /data/backup. where /data is the mount point and backup is the directory in it. Also checked - Backup directory is a mount? checkbox.

    Note: the main hdd is a ssd and second is standard hdd, which I formatted and added after ispconfig3 installation.

    How I can fix both these issues?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Where does this script come from?
    Is quota set up for the partitions you are using? Compare what you have with the quota setup in Perfect Server Guide.
    If the ISPConfig installed with an automated script fails, I would just ditch that script and install following the Perferct Server Guide.
     
  3. pawan

    pawan Member HowtoForge Supporter

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Check /etc/fstab file and compare your file with the instructions from perfect server guide.
     
  5. pawan

    pawan Member HowtoForge Supporter

    Hi Till,
    I used - quotaon -avug
    the quota is working now.
    Not sure whether that was run by the auto installer.

    besides this I have another issue as mentioned in my post regarding the backup, how can I resolve the same?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Test that your mounted backup drive is writable by creating a file there. Maybe you mounted it read-only instead of rw mode.
     
  7. pawan

    pawan Member HowtoForge Supporter

    yes Till, I created a file and save it in backup folder without any issue.
    relevant output of mount command.
    /dev/sdb1 on /data type ext4 (rw,relatime,data=ordered)
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please uncheck it as your backup directory is permanetly mounted.

    Did the backup work before you changed that folder?
    Are the Linux zip and unzip command installed?
     
  9. pawan

    pawan Member HowtoForge Supporter

    Hi Till, what is the diff. between temporarily mounted and permanently mounted.
    I haven't added this in fstab. only mounted it using mount command - mount /dev/sdb1 /data
    No I didn't checked that. if you think that will help, then I will restore the default and update you.
    yes I checked it is installed.
     
  10. pawan

    pawan Member HowtoForge Supporter

    Still no luck.
    I changed the path to default /var/backup.
    but I still don't see any backup.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    You can run the backup manually like this as root user:

    cd /usr/local/ispconfig/server
    php cron_debug.php --cronjob=500-backup.inc.php

    For email backups, use:

    cd /usr/local/ispconfig/server
    php cron_debug.php --cronjob=500-backup_mail.inc.php
     
  12. pawan

    pawan Member HowtoForge Supporter

    Thanks Till,
    Just an update I can see the backup in control panel now after updating to /var/backup.
    but I reverted the path to mount path again and run the commands you suggested and it is creating the backup in mount/hdd as well.
    may be I think UN-selecting checkbox will work with mount as well. my only reason I couldn't see backup immediatly as I was putting the time in control panel as per India, but system time was most likely it was USA.
    That is when it was 3.10AM I was selecting 3.15AM in the time in control panel, which obliviously won't create any backup as system time being different.
    Now I have updated the system time as well. I will wait and update if I still face the issue.
     

Share This Page