Quota not installing

Discussion in 'Installation/Configuration' started by mysterytoy, May 15, 2018.

  1. mysterytoy

    mysterytoy New Member HowtoForge Supporter

    Good Afternoon,

    I purchased a couple of machines that I thought were great. They came with a 249GB SD drive and a 1TB hard disk. The Centos install went fine.

    I am installing Centos 7.4 and using the perfect server tutorial. I can't get quota to install. I don't really need it so I continued with the rest of the tutorial and then ran the ispconfig migration tool to port over all the settings from my current production server. The migration stopped when it was copying some of the web sites with an error that MySQL stopped responding. I though maybe I ran out of space but that wasn't the case. I can log in as one of the FTP users but cannot copy files to the web site. I opened up shell windows in both old and new server and the usernames and permissions look correct.

    Is it a problem to install ISPConfig 3.11 without Quota? Is there another way to install Quota? Any help would be appreciated.
     
  2. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    Sorry I can't help you with the migration tool - @Croydon or @till may.
    According to the issue with quotas. Have you installed quota support?
    Is it a (part)virtualized machine without quota support? Does this help: https://www.linuxtechi.com/enable-user-group-disk-quota-on-centos-7-rhel-7/ ?

    Maybe you need to fine tune your database server to handle your requests or... check the default size of your partitions, only because you have a ssd or 1tb disk doesn't mean the default image does make use of one or the other or 100% of it ... yeah this happens.

    check your disk usage with
    Code:
    $df -h
     
  3. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You should check, that the mysql-server on the target-server is still running and did not reach any limits. IIRC the mig-tools copies the databases to /tmp on the target. You should check the disk-space for /tmp, too.
     
  4. mysterytoy

    mysterytoy New Member HowtoForge Supporter

    Thanks for your help. It doesn't seem to be disk space I think. Here's the result of the command above:

    [[email protected] ~]# df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/mapper/centos-root 50G 17G 34G 34% /
    devtmpfs 7.6G 0 7.6G 0% /dev
    tmpfs 7.6G 0 7.6G 0% /dev/shm
    tmpfs 7.6G 9.2M 7.6G 1% /run
    tmpfs 7.6G 0 7.6G 0% /sys/fs/cgroup
    /dev/sda2 1014M 191M 824M 19% /boot
    /dev/sda1 200M 9.8M 191M 5% /boot/efi
    /dev/mapper/centos-home 1.1T 33M 1.1T 1% /home
    tmpfs 1.6G 0 1.6G 0% /run/user/0
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    What you might try is to set "max_package_size=1G" in the [mysqld] section in my.cnf file and restart MariaDB.

    If you need further help with the migration tool, then please contact us here:

    http://www.ispconfig.org/get-support/?type=migration
     
  6. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    maybe have a watch on aborted / timed out mysql connections aswell
     

Share This Page