Quota necessary?

Discussion in 'Installation/Configuration' started by globiws, Jun 27, 2012.

  1. globiws

    globiws New Member

    I am looking to use ISPConfig in a production cluster. Since there will be paid support plans soon, this makes it a much more attractive alternative.

    Like many, I am installing on virtualized servers - in my case Rackspace cloud servers. And like many, I cannot get quota to work on these machines.

    Quotacheck works fine, but quotaon returns multiple errors, including not being supported on the kernel.

    Now, I am looking to change my corporate billing process, and move away from traditional hosting "plans", and simply charge for disk space and bandwidth actual usage.

    The ISPConfig interface shows bandwidth, but I'm having a few strange behaviours with disk usage, probably due to quota. The usage is not being updated properly, but every now and then, it is.

    I'm assuming that real-time updating is not working because quota is not running, but when I run quotacheck, it updates things.

    I'm not totally sure yet, because I've only noticed this, and haven't tested all the way.

    Can someone please clarify for me how ISPConfig calculates disk space used, and what it needs for this? Is quota required, and what does quota REALLY do? And how does ISPConfig calculate MySQL and mail disk usage?

    Thanks,
    -Andreas
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig calls the command !repquota" and displays its output. Thats all.

    There is no mysql quota.
     
  3. globiws

    globiws New Member

    Thank you.

    I have confirmed that it is quotacheck which fixes the stats.

    When I ran repquota, it gave wrong readings (old).
    After quotacheck, repquota had the correct stats.

    Is this supposed to run daily or something? Or do I need to add a cron job to run quotacheck?

    Is there a workaround to get the space used by a client's mysql db's?

    Cheers,
    -Andreas
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Normally it has to be run just once after you installed quota and never again. Seems as quota is broken on your filesystem if you have to run it again.

    Mysql has no quota implemeneted and the mysql databases belong to the mysql user and not web user, so they dont fall under the website quota limit.

    The only thing you might do is to write a plugin that queries mysql for the database sizes even if it can not restrict the size or you use the du command on the shell to get the size of the directory which contains the database. But the du command will work only for myisam tables and not innodb.
     

Share This Page