Quota.Jailkit on SD cards

Discussion in 'General' started by sghazagh, Jul 26, 2019.

  1. sghazagh

    sghazagh Member

    Hello all,
    I am using ISPConfig on ARM architecture (Tinker Board, Raspberry pi,...) and it actually works great.
    Except, I cannot setup quota/jailkit as my rootfs running on SD card.
    My question is, does initially Quota/Jailkit work on EXT4 partitions running on SD card?
    Is it partition dependent or hardware is important?
    I am asking this, because when I add option ",usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0" to my /etc/fstab file, the command "
    mount -o remount /" does not work as it says: "mount: /: mount point not mounted or bad option."

    Here is my fstab:
    Code:
    proc            /proc           proc    defaults          0       0
    /dev/mmcblk0p1  /boot           vfat    defaults          0       2
    /dev/mmcblk0p2  /               ext4    defaults,noatime,errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0   0       1
    
    Any help?
     
    Last edited: Jul 26, 2019
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Does quota work after reboot?
     
  3. sghazagh

    sghazagh Member

    I didn't try, as if the fstab is not correct, the system won't boot.I only tried to check it first with "mount -o remount /" command which does not work.
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If you pasted your fstab in CODE tags it might be readable on this forum.
    Is your question "what error is in my fstab?"
     
  5. sghazagh

    sghazagh Member

    Cannot see the code tag when I edit the post. That's why I couldn't put it in CODE block.
    Not sure what tag should I manually use for CODE block.

    Anyway,
    my question is that does quota work on SD at all or not? (FSTAB option works fine on Ubuntu x86_64 but not on armhf architecture)
    I was wondering that's the Ubuntu ARM issue or that's because of the EXT4 partion on SD!!

    (EDIT: found the CODE tag)
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    It works.
    Maybe your problem is with the remount command, that may have wrong options.
    Code:
    mount -o remount,rw /dev/mmcblk0p2  /   
     
  7. sghazagh

    sghazagh Member

    In "Perfect Server ISPConfig" guide also mentioned the same command.
    I just thinking maybe the fstab options working on x86_64 are not embedded in armhf.
    That is the thought I need someone to confirm!
     
    Last edited: Jul 26, 2019
  8. sghazagh

    sghazagh Member

    Your command doe not uses the fstab option as it just mount the root to /dev/mmcblk0p2.
    To read fstab option it has to be "mount -o remount /" means read the options from fstab file.
    And in that case the options are not correct.
     
  9. sghazagh

    sghazagh Member

    Found it, as my kernel is custom compile of mine, I didn't include the QUOTA option in my kernel.
    Have to enable it first then probably the quota will work afterward.

    Code:
    zcat /proc/config.gz |grep QUOTA
    
    CONFIG_NETFILTER_XT_MATCH_QUOTA=y
    # CONFIG_NETFILTER_XT_MATCH_QUOTA2 is not set
    CONFIG_XFS_QUOTA=y
    # CONFIG_QUOTA is not set
    # CONFIG_QUOTA_NETLINK_INTERFACE is not set
    CONFIG_QUOTACTL=y
    
     
  10. sghazagh

    sghazagh Member

    All,
    I can confirm that by enabling the required kernel option the "mount -o remount /" command does not complain anymore.
    Code:
    zcat /proc/config.gz |grep QUOTA
    CONFIG_NETFILTER_XT_MATCH_QUOTA=y
    # CONFIG_NETFILTER_XT_MATCH_QUOTA2 is not set
    CONFIG_XFS_QUOTA=y
    CONFIG_QUOTA=y
    # CONFIG_QUOTA_NETLINK_INTERFACE is not set
    CONFIG_PRINT_QUOTA_WARNING=y
    # CONFIG_QUOTA_DEBUG is not set
    CONFIG_QUOTA_TREE=y
    CONFIG_QUOTACTL=y
    
    However, I still have issue as the command "quotacheck -acvugm" doe not work. the error is:
    Code:
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.
    
    Not sure why it's looking for /dev/root however, any help will be appreciated!
     
  11. sghazagh

    sghazagh Member

    Ok resolced it by :
    Code:
    ln -s /dev/mmcblk0p2 /dev/root
    
    and "quotacheck -acvugm " and "quotaon -avug" both works.

    To have /dev/root available in each reboot, I have added the "ln -s" command to /etc/rc.local .
    Code:
     RESULT
    [email protected]:~# ls /dev/root
    lrwxrwxrwx 1 root root 14 Jul 27 12:11 /dev/root -> /dev/mmcblk0p2
    [email protected]:~# quotacheck -avugm
    quotacheck: Scanning /dev/root [/] done
    quotacheck: Checked 20237 directories and 145617 files
    [email protected]:~# quotaon -avug
    /dev/root [/]: group quotas turned on
    /dev/root [/]: user quotas turned on
    [email protected]:~#
    
    Hope it help others....
     
    till likes this.

Share This Page