Quota In Xen Virtual Machines

Discussion in 'HOWTO-Related Questions' started by tmaleshafske, May 19, 2008.

  1. tmaleshafske

    tmaleshafske New Member

    I cannot figure out how to get quota support in a XEN virtual machine... Is this even possible? And how do you set it up. The way of doing it in the Perfect Server set-up doesn't work.

    Appreciate the help
     
  2. falko

    falko Super Moderator ISPConfig Developer

    It should. Do you get any errors?
     
  3. tmaleshafske

    tmaleshafske New Member

    I'll have to try it again. As soon as I do I will post the output
     
  4. tmaleshafske

    tmaleshafske New Member

    here is the error message:

    Code:
    root@males005:~# vim /etc/fstab
    root@males005:~# touch /quota.user /quota.group
    root@males005:~# chmod 600 /quota.*
    root@males005:~# mount -o remount /
    mount: / not mounted already, or bad option
    root@males005:~# 
    
    here is a copy of my /etc/fstab
    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/hda1 none swap sw 0 0
    /dev/hda2 / ext3 noatime,nodiratime,errors=remount,usrquota,grpquota-ro 0 1
    
    Thanks for the help :)
     
  5. falko

    falko Super Moderator ISPConfig Developer

    If mount -o remount / doesn't work, reboot the VM - it has the same effect. :)
     

Share This Page