Quota format not supported in kernel

Discussion in 'Installation/Configuration' started by oddo, Mar 13, 2006.

  1. oddo

    oddo New Member

    Hi
    I have a problem when I try to instal ispconfig on debian 3.1 (Debian Sarge Netinstall CD).

    when I run:
    quotaon -avug

    i get this error:
    Code:
    quotaon: using //aquota.group on /dev/md0 [/]: No such process
    quotaon: Quota format not supported in kernel.
    quotaon: using //aquota.user on /dev/md0 [/]: No such process
    quotaon: Quota format not supported in kernel.
    i have 2 hard-drivers in RAID -> /dev/md0

    what do i have to do to make it work ... ?
    thx
     
  2. falko

    falko Super Moderator

    What's in /etc/fstab?

    You can try
    Code:
    modprobe quota_v1
    modprobe quota_v2
    and then
    Code:
    quotaon -avug
    again.
     
  3. oddo

    oddo New Member

    where do i have to write ...
    Code:
    modprobe quota_v1
    modprobe quota_v2
    /etc/fstab
    ------------------------------------------------------------------------
    <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/md0 / ext3 defaults,errors=remount-ro,usrquota,grpquota, 0 1
    /dev/hda1 /boot ext3 defaults 0 2
    /dev/md1 none swap sw 0 0
    /dev/hdd /media/cdrom0 iso9660 ro,user,noauto 0 0
    ------------------------------------------------------------------------
     
  4. till

    till Super Moderator

    Execute the command in the shell as root user.
     
  5. oddo

    oddo New Member

    Code:
    office:~# modprobe quota_v2
    Warning: loading /lib/modules/2.4.27-2-386/kernel/fs/quota_v2.o will taint the kernel: no license
    See http://www.tux.org/lkml/#export-tainted for information about tainted modules
    Module quota_v2 loaded, with warnings
    office:~#
    
     
  6. oddo

    oddo New Member

    Code:
    
    modprobe: Can't locate module quota_v1
    office:~# modprobe quota_v1
    
    
     
  7. oddo

    oddo New Member

    office:~# quotaon -avug
    /dev/md0 [/]: group quotas turned on
    /dev/md0 [/]: user quotas turned on


    thx ;)
     
  8. till

    till Super Moderator

    Please try to run the command:

    quotaon -avug

    Did you get still errors?
     
  9. falko

    falko Super Moderator

    Please append quota_v2 to /etc/modules so that it will be loaded automatically whenever you reboot the server.
     
  10. oddo

    oddo New Member

    i added quota_v2 in /etc/modules

    thanks falko
     

Share This Page