Quit the install process, cannot uninstall

Discussion in 'General' started by effoo, Oct 7, 2018.

  1. effoo

    effoo New Member

    Hello,

    I quit the ISPConfig install process and now none of the install/uninstall/update.php files are usable.
    "install.php" sees an installed ISPConfig and wants me to use update.php.
    "update.php" shows these errors:
    Code:
    Operating System: Debian 9.0 (Stretch) or compatible
    
    PHP Warning:  include_once(/usr/local/ispconfig/server/lib/config.inc.php): failed to open stream: No such file or directory in /tmp/ispconfig3_install/install/update.php on line 107
    PHP Warning:  include_once(): Failed opening '/usr/local/ispconfig/server/lib/config.inc.php' for inclusion (include_path='.:/usr/share/php') in /tmp/ispconfig3_install/install/update.php on line 107
    PHP Notice:  Undefined variable: conf in /tmp/ispconfig3_install/install/update.php on line 108
    Unable to resolve hostname
    And "uninstall.php" shows these errors:
    Code:
    PHP Warning:  require_once(/usr/local/ispconfig/server/lib/config.inc.php): failed to open stream: No such file or directory in /tmp/ispconfig3_install/install/uninstall.php on line 37
    PHP Fatal error:  require_once(): Failed opening required '/usr/local/ispconfig/server/lib/config.inc.php' (include_path='.:/usr/share/php') in /tmp/ispconfig3_install/install/uninstall.php on line 37
    Is it possible to recreate/rebuild those missing files just for the sake of uninstalling and installing ISPConfig again?
    I don't have any data that needs to be worried about.

    Thank you in advance
     
    Last edited: Oct 7, 2018
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Delete the folder /usr/local/ispconfig
    2) If there is already a mysql user or a dbispconfig database, then delete them with phpmyadmin.
    3) install ispconfig again by using install.php
     
  3. effoo

    effoo New Member

    Well thank you very much for that quick reply. The install process starts now!
     
  4. effoo

    effoo New Member

    Now ISPConfig is running, but is very slow, the web view is missing some html elements and links do not function. For example if I manage to go to clients, the loading spinner never stops.
    ispconfig.log is empty

    https://www.howtoforge.com/community/threads/ispconfig-viewing-probelms.534/
    this folder "admispconfig" does not exist

    Update:
    I completely had to restart the server and now I get a response from ISPConfig. I think some php stuff went rogue.

    Update2:
    Nope, it is definately lagging hard again.
    Found this in the Apache error.log hundreds of times:
    Code:
    AH00106: piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" /var/log/ispconfig/httpd' failed unexpectedly
    [vlogger] target directory /var/log/ispconfig/httpd does not exist or is a symlink - exiting.
     
    Last edited: Oct 7, 2018
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if the installation is still not complete. Try to create the missing log directory manually:

    mkdir /var/log/ispconfig/httpd
     
  6. effoo

    effoo New Member

    Thank you for your tipps but in the end I uninstalled everything, deleted relevant folders & config files manually and hope that I got them all...
     

Share This Page