Questions regarding Rspamd spam filtering

Discussion in 'Installation/Configuration' started by snowweb, Sep 9, 2020.

Tags:
  1. snowweb

    snowweb Member

    Where to find the GUI control area mentioned by Taleman in this post? He mentions that he has the ability to train the filters as ham/spam and can review logs of it's actions.
    Currently, all I see that is available to me in my Control Panel are 4 settings.
    Also, which headers are being added by this Rspamd? is it the nice X-Spam headers (they have a nice lot of info in them) but if X-Spam headers are from Amavis then I'm worried that we will have even less ways to understand how Rspamd is working in the future after Amavis is removed?
     
  2. snowweb

    snowweb Member

    Please don't worry now! I just found an option to change from Amavis to Rspamd and noticed that when I switched it, before saving the setting, it displayed the details for accessing a control panel for it. This also confirms that it wasn't running previously and therefore the headers I was seeing were generated by Amavis, but maybe Rspamd will do the same too. Let's see!
     
  3. snowweb

    snowweb Member

    I've just tried to access the control panel through the link displayed next to the config setting where I enabled Rspamd but it says:
    I noticed that the control panel link is for port 8081 but I'm not sure that my certificate would cover that? How can I fix this please? I've tried accessing by http:// but that doesn't work either. Also tried same path but port 8080 and 80. Still no joy.
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Are you sure that is the website you set up for RSpamd?
    Did you set up SSL certificate for that rspamd website?
    Certificate is for the FQDN, so it should cover all ports.
     
  5. snowweb

    snowweb Member

    Hi Taleman,
    When you switch from Amavis to Rspamd in the ISPConfig control panel, there is a link displayed automatically. The link is in the format of https://myserverdomain.com:8081/rspamd/ .
    I didn't then go and create any settings for this, as I imagine if the link was displayed, this should already be working.
    "myserverdomain.com" (substituted for my actual domain name), is the fqdn of my ISPConfig server and indeed, ISPConfig Control Panel is running on "https://meserverdomain.com:8080" without any issues.
    I think this may be a configuration error of ISPConfig, when it automatically enables the site: https://myserverdomain.com:8081/rspamd/ , I'm not sure where to look for that though.
     
  6. snowweb

    snowweb Member

    I have found a vhost directive in /etc/apache2/sites-available/apps

    Upon checking /var/www/apps/rspamd/ it seems that the rspamd directory has not been created. The apps directory is empty. This would seem to me to be the problem? If I'm correct, how can I fix this please and is this an issue/bug with ISPConfig?
     
  7. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    A Location is part of URL, not a Directory path.
     
    snowweb likes this.
  8. snowweb

    snowweb Member

    Thanks Jesse.
    So it's not that then.
     
  9. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    So /rspamd proxies to localhost port 11334 - do you have anything listening on port 11334 of your ISPConfig master server?
     
  10. snowweb

    snowweb Member

    That's a good point! No
    shows nothing listening.
    Not quite sure what to do about it though.
    Is Rspamd a service which can be restarted, because I tried restarting it and got
     
  11. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    I've not tried using the rpamd gui yet, but just checking a setup here, I find rspamd will run on the mail server of a a multi-server system, so I suspect you must do something to make the /rspamd location of your app server (ispconfig master server) connect to rspamd of a mail server node; a few ways come to mind to make that work for a single mail server; I've not put more than a few moments thought into how to wire that up for multiple mail servers, but nothing immediately comes to mind.

    For a single slave mail server you could either 1) use an ssh tunnel to connect 127.0.0.1:11334 on the master server to 127.0.0.1:11334 on your slave mail server, or 2) change the slave mail server to bind to '*' or another (non-localhost) ip, then change the url that /rspamd proxies to (don't forget to protect port 11334 on your mail servier with firewall rules in this case).
     
    snowweb likes this.

Share This Page