Questions About "The Perfect Server - CentOS 6.4 x86_64 (nginx, Dovecot, ISPConfig 3"

Discussion in 'HOWTO-Related Questions' started by franck63, Oct 21, 2013.

  1. franck63

    franck63 New Member HowtoForge Supporter

    Hello There

    Trying to configure my dns server

    I have a couple of questions

    If I type "hostname" at console prompt I get "server1" shouldn't it be a FQDN style like ""​

    In ISPConfig3, when I go to system tab
    the page shows only one line with "1" in each column but the server name is not displayed! Is this correct?

    in part 19 on line where "... and make sure that the ROOTDIR=/var/named/chroot line is comment out:"
    does it mean that "#" has to be there​

    Thank you in advance for much the appreciated help.

    Best Regards

    Attached Files:

  2. franck63

    franck63 New Member HowtoForge Supporter

    Also I have noticed that the file "/etc/named.conf.local" is empty
    Is this correct !!?​
  3. Quaxth

    Quaxth New Member

    Check in Server Config that the host name is set correctly like:
    If not, open in SSH Server Terminal the file hosts
    vi /etc/hosts
    it should looks like:
    if not, change the IP to the one of your server and the domain include the alias to your servers domain name with the Alias again after the domain (as shown).

    Restart networking after that.

    If you read the Perfect Server Guide ....... you'll find all needed informations.
    Last edited: Oct 22, 2013
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The hostname should be corrected like Quaxth explained, but thats all not related to running a dns server. If you have a problem with dns, then please describe your problem and post the dns zone and records that you created in the dns manager.
    Last edited: Oct 22, 2013
  5. franck63

    franck63 New Member HowtoForge Supporter

    Quaxth, Till,

    Thank's for the replies.

    Quaxth, Indeed there was a problem with my host file. I have fix it.
    Rebooted the server (still same result as in picture)
    I should mention the file also has an entry for my Win PDC could that be interfering.

  6. franck63

    franck63 New Member HowtoForge Supporter

    Also I should mention that the server config page has one empty line.

    How can I fix this
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    If it has just one line, then its ok. If the first part is empty, then you have to set the hostname in ispconfig.
  8. Quaxth

    Quaxth New Member

    I think that Till or Falko need to "jump" in for the problem

    Of topic: If you would use the free service of you could upload the picture to there and just use the link to the picture to place in post's. That has the advantage for to get full size displayed and not resized and may be difficult to see what they show!
    At postimage they also having an nice screencapture apps which will be in system bar, lower right. set setting for to capture, click on that icon and select the area with mouse which you like to capture, right click in caprured area and click upload. Wait a moment and as the link to the picture appears, right click and chose upload. In you post use the [​IMG]
    That's all and the picture will appear you post like this:
    The Postimage Icon is that between the Nvidia and SC Icon, need to be set to show all times.
    Don't need to sign up but you could do that for free as well and than get an API Key too!
  9. franck63

    franck63 New Member HowtoForge Supporter

    Thank's Quaxth!

    I will try your suggestion for images... looks good.

    I have subscribed and downloaded the book... and working on try to find solution.

    Any clues hon ow to you get to phpmyadmin to look in the ispconfig setup.


  10. Quaxth

    Quaxth New Member

    Just use and you should be on the login page!
  11. franck63

    franck63 New Member HowtoForge Supporter

    Answer to the phpmyadmin question :eek:

    append :8081/phpmyadmin to server path
  12. Quaxth

    Quaxth New Member

    Sorry Franck, I use Apache with ISPConfig.

    You may use PuTTY from Terminal and/or WinSCP from within Windows. Later may is more easy to use and you could just open the .conf files etc. with double click.

    WinSCP is Freeware and you couls just download from Internet. Be careful with it, it has a lot power!

    Regarding PhpMyAdmin, I just type in browser the Server's IP or the domain with /phpmyadmin on the end and I'm at the log on.
  13. franck63

    franck63 New Member HowtoForge Supporter


    Quaxth, about phpmyadmin I found it
    yes I'm using both putty and winscp.

    Till, yes I understand about the server name issue but how do I fix it
    i.e. via ISPConfig (could not find) the tabs are not there.

    In the mean time I've deleted bad entries in system->server and In system->server->config.

    I restarted the ISPConfig

    But then I get
    So I tried ping got 100% packets loss

    Now I went system-config-network

    on eth0 I set it like this
    Default gateway IP (pfsense router)
    Primary DNS Server (Win PDC)
    Secondary DNS Server (pfsense router)

    Is THIS correct I dout because stil no ping

    In DNS settings
    host name : (It was not FQDN previously) hoopefullyu I've fixed a problem here.
    Primary DNS (WinPDC)
    Secondary DNS (pfSense)
    Tertiary DNS empty
    DNS search path

    Does that make sense.

    Thank you very much for your help.

    Best Regards
  14. franck63

    franck63 New Member HowtoForge Supporter

    Problems fixed proceding with ddns setup

    Hey Quaxth, Till,

    I have managed to fix all basic problems with my ISPConfig setup

    I am now moving with the DNS Setup

  15. franck63

    franck63 New Member HowtoForge Supporter


    I need to setup my subdomain.

    I have implemented DynDNS to fix my dynamic public address issue.
    I have made proper redirection with my public host with a CNAME record.
    I can now ping my internal domain name.

    The setup for my ISPconfig Server and DNS is like this.

    IP: /
    hostname is​

    DNS Zone:
    DNS Zone records:
    A mail
    A www

    When I nslookup my LAN my internal domain it displays the ip of my Windows PDC. ???
    When I nslookup the WAN I get
    Non-authoritative answer: canonical name =
    Address: (my router WAN ip)

    So something is working!

    If I try to nslookup my or my
    I get noting and an error: namerror.

    Any sugestion or adive would help greatly.

    Best Regards
    Last edited: Oct 24, 2013
  16. Quaxth

    Quaxth New Member

    I'm not sure you could get Dynamic DNS working on ISPCopnfig.

    Problem seems to be that the IP isn't rsolving to your own server, instead to the DynDNS Server. I don't know and never worked with DynDNS, in NO-IP that problem could be solved if you use, and pay for it, and enhanced Service. As free Service, it wouldn't work either.

    You may run an normal website via DynDNS, that would work, but and Hosting Site and Server.

    If I'm wrong, and hopefully I am(!), the experts from Germany could explain.

Share This Page