question of permissions and proprietors

Discussion in 'Installation/Configuration' started by albertux, Oct 17, 2007.

  1. albertux

    albertux New Member

    I believe that this question does not have relation to the ispconfig server, but i need some help ...

    Some users have installed de Joomla CMS in the ispconfig server and all good works, but at the time of uploads to modules or templates through Joomla, this modules or templates they maintain the permissions of the apache web server (www-data), with wich these modules or templates cannot be eliminiated or be modified from Joomla CMS ...

    now, as i have it to do so that the modules or templates conserve the owner given by ispconfig server?

    the modules are to much specials because when they uploads, the tables within the data base of the user are created automatically.

    :) some idea to conserver the user ????

    bye ...
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. albertux

    albertux New Member

    Hi Till, i installed the suphp as you said me, i said myself step by step in the documentation and obtained that it worked, But whenever now active the square of "PHP Scripts" in the administration of the Web-site, Error appears to me "500 - Internal Error of the server" .... some idea ???

    i use the version 2.2.14 of the ispconfig server and apache 2.2.3, suphp 0.6.2 and php 5.0.2-8+etch7 ....

    believe that it must be some line that this affecting everything, but I do not know as it could be...

    it would be thankful that again you helped me, since with this would almost have the server to the 100%

    greetings
    albertux

    P.D. i need some idea ... ;)
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Have a look at the error log of the webiste. Most likely the files are not owner by the web admin.
     
  5. albertux

    albertux New Member

    look,

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    this is the error... some idea ????
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not a error from a logfile. Please look into the logfile and post the error that is logged there. The real reason for the error is never send to the browser.
     
  7. albertux

    albertux New Member

    ups, sorry ...

    [Sat Oct 20 13:58:20 2007] [error] [client 190.161.213.146] LookupException in API_Linux.cpp:98: Could not lookup username "wwwrun"

    [Sat Oct 20 13:58:20 2007] [error] [client 190.161.213.146] Premature end of script headers: index.php

    this he the log :confused: mmmm


    I analyzed and the API_Linux still is in /tmp/suphp-0.6.2/src/API_Linux.cpp
     
    Last edited: Oct 20, 2007
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that the website has a user where you checked tha "administrator" checkbox and that all files in the website belong to this user.
     
  9. albertux

    albertux New Member

    hi Till you right again, but don't work and in order to assure that all I have done it well, upload another site completely through ispconfig server, creating the usuary administrator, I reviewed the permissions, and all the others but it didn't work either :( ... and the error is the same :

    LookupException in API_Linux.cpp:98: Could not lookup username "wwwrun"

    Premature end of script headers: index.php

    but as it said to the user and group to you in all the site is correct...

    thanks for your help again and I wait for your commentaries.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    grep wwwrun /etc/passwd
    ?

    Do you use SUSE? If so, is AppArmor disabled?
     
  11. albertux

    albertux New Member

    Hi, with the grep wwwrun /etc/passwd he doesn't appear nothing... and no i work just with Debian Etch ...

    i need to created it????

    greettings
     
    Last edited: Oct 21, 2007
  12. falko

    falko Super Moderator ISPConfig Developer

    wwwrun is the name of the Apache user on SUSE; on Debian it's www-data.

    Are you using wwwrun somewhere in your scripts? Replace it with www-data.
     
  13. albertux

    albertux New Member

    ok, you are right man thank's, the problem that not yet works the suphp :(

    before it had the following errors

    - LookupException in API_Linux.cpp:98: Could not lookup username "wwwrun"
    - Premature end of script headers: index.php

    I changed the user as you said to me in the /etc/suphp.conf file, but the error stays :

    - Premature end of script headers: index.php

    and the page is in target, that is freezing (i don't know say), I wait for ideas and commentaries since I do not know that to do more...

    greetings
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look again at the error.log file and post the error that is reported now.
     
  15. albertux

    albertux New Member

    [Mon Oct 22 13:14:29 2007] [error] [client 190.161.213.146] Premature end of script headers: index.php

    no more :confused: :confused:

    and the /var/log/suphp.log say this :

    [Mon Oct 22 13:20:32 2007] [info] Executing "/var/www/web18/web/index.php" as UID 10048, GID 10018
     
    Last edited: Oct 22, 2007
  16. albertux

    albertux New Member

    ohhhh, thanks all the configuration files is this :


    [global]
    ;Path to logfile
    logfile=/var/log/suphp.log

    ;Loglevel
    loglevel=info

    ;User Apache is running as
    webserver_user=www-data

    ;Path all scripts have to be in
    docroot=/

    ;Path to chroot() to before executing script
    ;chroot=/mychroot

    ; Security options
    allow_file_group_writeable=true
    allow_file_others_writeable=false
    allow_directory_group_writeable=true
    allow_directory_others_writeable=false

    ;Check wheter script is within DOCUMENT_ROOT
    check_vhost_docroot=true

    ;Send minor error messages to browser
    errors_to_browser=false

    ;PATH environment variable
    env_path=/bin:/usr/bin

    ;Umask to set, specify in octal notation
    umask=0077

    ; Minimum UID
    min_uid=100

    ; Minimum GID
    min_gid=100

    [handlers]
    ;Handler for php-scripts
    x-httpd-php=php:/usr/bin/php5-cgi

    ;Handler for CGI-scripts
    x-suphp-cgi=execute:!self

    it was only a configuration problem now it works :) and i'm happy :) thaks all again
     

Share This Page