Question about quotas

Discussion in 'Installation/Configuration' started by metaldrummer, Nov 16, 2007.

  1. metaldrummer

    metaldrummer New Member

    Hi all:
    My config:
    OpenSuse 10.1
    Ispconfig 2.2.12

    In this image

    [​IMG]

    can view report for quotas via email message. How can block this. I want my customer cannot over quota for website and emails.

    And this

    [​IMG]

    how block email quota for cannot over defined space?

    Regards
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Run
    Code:
    crontab -e
    and comment out the line that sends the quota messages.

    I guess this is caused by the log files. They are copied into the user's account as root and chmoded afterwards, that's why a user can get over his quota (but only in this case). Simply delete some unused log files in the user's account.
     
  3. metaldrummer

    metaldrummer New Member

    Falko Thanks, but I need to know is because as shown in the first image, the system allowed him to store more information (size), which has defined the group account. And know why the system on the other imagne allows a user account accepts more information on your mail box that is defined. How can I make it so that the system will not allow this to happen?
    Regards
    David Lagos S.
    Coquimbo-Chile
     
  4. falko

    falko Super Moderator ISPConfig Developer

    I've explained it already:
    I guess this is caused by the log files. They are copied into the user's account as root and chmoded afterwards, that's why a user can get over his quota (but only in this case). Simply delete some unused log files in the user's account.
     
  5. metaldrummer

    metaldrummer New Member

    Perfect. Then on the basis that it is possible to halt the saving of those or are necessary for the proper functioning of webalizer?. Besides these log are used to be shown in the statistics that appear in the administration of each site?.
    Besides my question was on the side to which the message shares the home user mailboxes, they appear exceeded (see second image). I occupied the space used to look (using the du command) for each side and that both are not the administrators of this site. So if there is any way that I can stop the postal receipt for that as much as for exceeding their allowed space or is not possible?. I doubt if the mail system is sending any message that the account is full and can not receive mail.

    Thanks.
    David Lagos S.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The logfiles are needed by webalizer. You can stop the coping of course, but you will loose the statistics then.

    Users can not receive messages when their mailbox is full, as the process runs under the ID of the user. maybe linux system quota is not configured correctly for the ahrddisk partition where your sites reside.
     
  7. metaldrummer

    metaldrummer New Member

    Sorry, I said wrongly. I am concerned that if the system sends a message box filled to the person who sends mail to my users?. Also installed ispconfig using the perfect setup for opensuse Linux 10.1
    The system of quotas is installed according to the guide. And strikes me that users can continue to receive messages and your mailbox will exceed its limit defined. As I understand one thing is the size of the account of my client and the other is the size defined for each mailbox.
    What could have defined wrong ... you need to send something to show repquota or something else?
    Thanks
    David
     
  8. falko

    falko Super Moderator ISPConfig Developer

    You can simply run
    Code:
    repquota -avug
    and it shows you the current quota usage.
     
  9. Genghis

    Genghis New Member

    I have a problem regarding the quota (check) also.
    The quota always worked fine for me in the past, untill I reinstalled my server and upgraded ISPconfig some time ago.
    I tried a lot of things posted here on the forum, but nothing seemed to be fixing my problem.

    The thing is: quotacheck thinks a specific user is going over his quota.

    Server: Debian Etch 4.0 (up to date)
    Kernel: 2.6.22.4-custom-grsec
    Kernel quota version: 6.5.1
    ISPconfig version: 2.2.18

    Reseller has no (value is -1) limit on traffic or space set (in ISPconfig webgui).
    User (web6_fakedomain) has a quota limit of 15001MB.
    The website (web6) itself is also set to 15001MB.
    The User (web6_fakedomain) is set to be the administrator of the site (the box is checked).

    repquota -avug gives me a lot of lines:
    some of the lines:
    Relevant info on the e-mail that is being sent out every day:
    I had to turn off the quota to make sure the user can upload anything, so not the best solution, but I was unable to find out what the problem is myself.

    Anyone has a solution, or can provide me with some info on what to investigate further?

    Thanks in advance.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    I guess that there are some huge log files in the logs directory in web6. If you don't need them, you can delete them (unless they are from the current month).
     
  11. Genghis

    Genghis New Member

    Nope, there are no big log files I'm affraid...

    Also; to find all files from user web6 on my system, I did a find / -user 10006 (10006 is the correct UID for user web6), and there are no files owned by that user, except for the 4 MB in the web6 directory.

    Any other thoughts?

    Thanks in advance!
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Did you take a look at the /tmp directory? Which ISPConfig version do you use?
     
  13. Genghis

    Genghis New Member

    Yup, because I did a search on the entire system.
    Anyway, I double-checked to make sure, and there is nothing in the /tmp
    dir that belongs to user web6.

    Also, as said in my first post, I am using ISPconfig version 2.2.18.

    Thank you,
    Genghis
     
  14. Genghis

    Genghis New Member

    This problem still persists. Anyone happen to find a solution yet, because for time being I had to disable the quota enforcement due to the false positive mails it is sending out...
     

Share This Page