question about hostname and domain

Discussion in 'Installation/Configuration' started by Ovidiu, Sep 19, 2005.

  1. Ovidiu

    Ovidiu Active Member

    I had already tried it like that but what happens is this:

    If I try and login into myIP:81/phpmyadmin it succeeds but I only see a blank screen with this url: https://h5810.serverkompetenz.net.h5810.serverkompetenz.net:81/phpmyadmin/

    when I log into ispconfig go to MANAGEMENT and hold the cursor over BACKUP DATA, CHECK DATABASE, etc. the cursor changes to a hand to indicate a link, but if I hover over ANYTHING below SYSTEM CONFIG the cursor does not change and I cannot click that link - somehow all those links are lost - ???

    any idea?
     
  2. falko

    falko Super Moderator

    What happens if you put

    Code:
    $go_info["server"]["server_url"] = "https://h5810.serverkompetenz.net:81";
    into /home/admispconfig/ispconfig/lib/config.inc.php and remove this part completely:

    Code:
    if(isset($_SERVER['SERVER_NAME']) && isset($_SERVER['SERVER_PORT'])){
    $go_info["server"]["server_url"] = 'https://'.$_SERVER['SERVER_NAME'].':'.$_SERVER['SERVER_PORT'];
    } else {
    $go_info["server"]["server_url"] = "https://h5810.serverkompetenz.net:81";
    }
    BTW, why does it say h5810.serverkompetenz.net.h5810.serverkompetenz.net instead of h5810.serverkompetenz.net?
     
  3. Ovidiu

    Ovidiu Active Member

    I just tried to change what you suggested, but I just managed to log myself out... tried changing the password while my internet connection dropped, maybe I mistyped the password, how do I reset the admin password for ispconfig ?

    well after the hanges you proposed her is the result: I type in admin and my passwd:

    I just tried accessing my ispcfg without https only http and it is configured for https, the error looks like this:

    well I do not know, I guess it has something to do with the hostname settings?
     
    Last edited: Mar 7, 2006
  4. till

    till Super Moderator

    These errors have nothing to do with the controlpanel URL. Please check that you have not deleted or altered the library path in the config.inc.php file.
     
  5. Ovidiu

    Ovidiu Active Member

    inside /home/admispconfig/ispconfig/lib/config.inc.php I cannot find the word library - what would that variable be called?

    so I went and undid the changes suggested further up and I am back to the initial problem...

    btw. I still think something is wrong with my hostname settings: hostname contains only this line: h5810.serverkompetenz.net and inside ispcfg panel I set host to h5810 and domain to serverkompetenz.net - is this right so far?
     
  6. till

    till Super Moderator

    The variables and their correct contents are:

    Code:
    $go_info["server"]["server_root"] = "/home/admispconfig/ispconfig";
    $go_info["server"]["include_root"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."lib";
    $go_info["server"]["classes_root"] = $go_info["server"]["include_root"] . $go_info["server"]["dir_trenner"] ."classes";

    Please replace these lines from your config.inc.php file:

    Code:
    if(isset($_SERVER['SERVER_NAME']) && isset($_SERVER['SERVER_PORT'])){
      $go_info["server"]["server_url"] = '{PROTOCOL}'.$_SERVER['SERVER_NAME'].':'.$_SERVER['SERVER_PORT'];
    } else {
      $go_info["server"]["server_url"] = "{URL}:81";
    }
    with:

    Code:
    $go_info["server"]["server_url"] = "https://h5810.serverkompetenz.net:81";
    when you use SSL encryption or with this:

    Code:
    $go_info["server"]["server_url"] = "http://h5810.serverkompetenz.net:81";
    when you dont use SSL.
     
  7. Ovidiu

    Ovidiu Active Member

    I followed your last advice and its working now, at least I cannot detect any more probs

    *big THX* to all of you for your patience and expertise ;-)
     

Share This Page