Q on "Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch)"

Discussion in 'HOWTO-Related Questions' started by Drywall, Aug 11, 2008.

  1. Drywall

    Drywall New Member

    Hi there.

    I've gone carefully through the steps to get postfix, courier, mysql et al working per the tutorial. Unfortunately, users aren't being recognized. When I send a message to the sample user I created, it bounces.

    <[email protected]>: unknown user: "ben"
    Reporting-MTA: dns; byrnecreative.com
    X-Postfix-Queue-ID: 24E20159C834E
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Sun, 10 Aug 2008 20:13:57 -0400 (EDT)

    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822;[email protected]
    Action: failed
    Status: 5.1.1
    Diagnostic-Code: X-Postfix; unknown user: "ben"

    Additionally, when I check /home/vmail nothing's been created.

    /var/log/mail.log gives some trivial-rewrite warnings but nothing else looks out of the ordinary, just logs that the user is unknown and bounces it back.

    Any help anyone could provide would be great.
  2. Drywall

    Drywall New Member

    Got it sorted out (sort of)

    So after looking at the warning in the postfix log, I realized that the problem was that the postfix setting for myhostname was the same as one of the virtual domains I had set up. Changing the postfix conf to a different hostname seems to have solved the problem.

    However, this isn't particularly desirable behavior. I now have the Postfix myhostname set as www.byrnecreative.com so that I could use byrnecreative.com as a virtual domain. Is there any way I can rectify this so that the postfix hostname is available as a virtual domain? Or, is there any reason to care that the myhostname uses the www prefix, maybe it's not an issue?
  3. falko

    falko Super Moderator ISPConfig Developer


    The current config is fine if you don't have virtual users of the form [email protected]www.byrnecreative.com. :)

Share This Page