Q: Multiple PHP Versions (Deb 9 / v3.2)

Discussion in 'ISPConfig 3 Priority Support' started by macguru, Oct 16, 2020.

  1. macguru

    macguru Member HowtoForge Supporter

    Hi,

    I followed this instruction to install PHP 7.3 on Debian 9/ISPConfig 3.2.
    https://www.howtoforge.com/tutorial...fig-3-from-debian-packages-on-debian-8-and-9/

    Additional PHP version is being shown up in System -> Additional PHP Versions, linked to particular client, with all path names from article.
    However, in Sites -> Website -> Edit -> PHP Version only "Default" is available (yes, double checked client match).
    Did resync and restart, all services "php-fpm7.0" "php-fpm7.3" and "apache2" running fine.
    Repeated for another site, even add default 7.0, list still shows only "Default". PHP set to "PHP-FPM".

    Apart from commands from article, I run "a2enconf php7.0-fpm; a2enconf php7.3-fpm"

    How to fix this, or I did something wrong?
    Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that you did not select a client in additional php settings.

    This should not be done as it changes the default php version and will cause you issued on your setup.
     
  3. macguru

    macguru Member HowtoForge Supporter

    I re-run
    update-alternatives --config php; update-alternatives --config php-cgi
    so /usr/bin/php -v shows correct version.

    System -> Additional PHP Versions -> Name -> Client must be EMPTY.
    Then the popup menu in web site settings shows a list of available stuff. Please update your article to reflect this, it took a considerable amount of time to fix
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    The article was written some time ago by a contributing author, I believe they would have to update it (and per issues discussed in the comments, they seem to have no inclination to do so).
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The article has been updated recently and it's perfectly fine, all issues mentioned in comments have been included in march. If you look at the screenshot in the article, then you see that the client field is empty, so the article is perfectly fine. And you can select a client there, but then this PGHP version is visible only to this one client, that's why you normally do not select a client.
     
    Jesse Norell likes this.

Share This Page