Pyzor discovery error

Discussion in 'HOWTO-Related Questions' started by markerman, Jul 21, 2008.

  1. markerman

    markerman New Member

    [email protected]:/home/markerman# pyzor --homedir /var/lib/MailScanner discover
    downloading servers from http://pyzor.sourceforge.net/cgi-bin/inform-servers-0-3-x
    Traceback (most recent call last):
    File "/usr/bin/pyzor", line 8, in <module>
    pyzor.client.run()
    File "/var/lib/python-support/python2.5/pyzor/client.py", line 1005, in run
    ExecCall().run()
    File "/var/lib/python-support/python2.5/pyzor/client.py", line 184, in run
    self.servers = self.get_servers(servers_fn)
    File "/var/lib/python-support/python2.5/pyzor/client.py", line 411, in get_servers
    servers.read(open(servers_fn))
    File "/var/lib/python-support/python2.5/pyzor/client.py", line 117, in read
    self.append(pyzor.Address.from_str(line))
    File "/var/lib/python-support/python2.5/pyzor/__init__.py", line 458, in from_str
    fields[1] = int(fields[1])
    IndexError: list index out of range

    any ideas?

    Thanks in advance
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Which distribution are you using?
    Which tutorial are you following?
     
  3. markerman

    markerman New Member

  4. Rocky

    Rocky New Member

    Hey,

    I beleive that is a bug in pyzor. Please try to redo it and let me know if it worked. I just did a setup 5 days ago and didn't have any problems.

    Rocky
     
  5. markerman

    markerman New Member

    I checked the server file that the discovery process records the IP of the Pyzor server. It states that the website cannot be contacted. I browsed to the website http://pyzor.sourceforge.net/cgi-bin...-servers-0-3-x in Firefox and was able to get to the parent site but got an error on the complete URL. That may be the issue. I'll wait to see if they fix it. I know it worked a few days ago. I was ablt to successfully do a Pyzor Ping a few days ago.

    James
     
  6. Rocky

    Rocky New Member

    Hey,

    It is very common for pyzor to timeout. Try editing the servers file and changing the IP to 82.94.255.100:24441.

    Rocky
     
  7. markerman

    markerman New Member

    I tried that and it did the same exact thing when I tried a Pyzor ping command. I scanned that IP to see if port 24441 is opened and it appears to be closed. Can you browse to "http://pyzor.sourceforge.net/cgi-bin...-servers-0-3-x" with firefox? You will see an error page. That is what is being put in the /var/lib/MailScanner/servers file with html tags. I also browsed to http://82.94.255.100 and a webpage "http://eva.i-block.com/" loaded. It's a German site and they do not have an english site. Port 24441 must be the service port pyzor uses. I'll bet that company stopped providing the service for free to Pyzor. Well anyhow I cannot continue with the "HowTo" until the pyzor issue is resolved. 3 days now. I'm almost ready to give up on this. How can this be reliable if it takes this long for developers to resolve issues with thier applications? (If thats the issue, it sure seems like it)
     
    Last edited: Jul 24, 2008
  8. Rocky

    Rocky New Member

    Hey,

    You're having a weird problem. I just did a pyzor ping and this is the response I'm getting:
    82.94.255.100:24441 (200, 'OK')

    I would redo section 7.2, making sure the you open the appropriate ports according to the guide.

    Rocky
     
  9. Hypnos

    Hypnos New Member

    "pyzor discover" basicly does a wget of http://pyzor.sourceforge.net/cgi-bin/inform-servers-0-3-x. That page has an CGI error, so you get a ~/.pyzor/servers file of a CGI error.

    Empty out the file and just put in "82.94.255.100:24441". It will work. I just installed pyzor on a machine this morning.

    It's not a TCP port, it's UDP. It's open.

    Pyzor is working just fine.
    Code:
    [[email protected] ~]# spamassassin -D < spam-mail.txt 2>&1 | grep -i pyzor
    [12449] dbg: plugin: loading Mail::SpamAssassin::Plugin::Pyzor from @INC
    [12449] dbg: pyzor: network tests on, attempting Pyzor
    [12449] dbg: config: fixed relative path: /var/lib/spamassassin/3.002005/updates                                          _spamassassin_org/25_pyzor.cf
    [12449] dbg: config: using "/var/lib/spamassassin/3.002005/updates_spamassassin_                                          org/25_pyzor.cf" for included file
    [12449] dbg: config: read file /var/lib/spamassassin/3.002005/updates_spamassass                                          in_org/25_pyzor.cf
    [12449] dbg: util: executable for pyzor was found at /usr/bin/pyzor
    [12449] dbg: pyzor: pyzor is available: /usr/bin/pyzor
    [12449] dbg: pyzor: opening pipe: /usr/bin/pyzor check < /tmp/.spamassassin12449                                          RODCK7tmp
    [12449] dbg: pyzor: got response: 82.94.255.100:24441 (200, 'OK') 7 0
    [12449] dbg: pyzor: listed: COUNT=7/5 WHITELIST=0
    [12449] dbg: rules: ran eval rule PYZOR_CHECK ======> got hit (1)
    [12449] dbg: check: tests=AWL,DIET_1,DIGEST_MULTIPLE,DNS_FROM_RFC_BOGUSMX,DNS_FR                                          OM_RFC_DSN,FB_CIALIS_LEO3,FM_MANY_DRUG_WORDS,FRT_DISCOUNT,FRT_VALIUM1,FRT_VALIUM                                          2,FR_ALMOST_VIAG2,FUZZY_MEDICATION,FUZZY_VLIUM,HELO_DYNAMIC_IPADDR,HS_INDEX_PARA                                          M,PYZOR_CHECK,RAZOR2_CF_RANGE_51_100,RAZOR2_CF_RANGE_E8_51_100,RAZOR2_CHECK,RCVD                                          _IN_PBL,RCVD_IN_SORBS_DUL,RDNS_NONE,REPTO_OVERQUOTE_THEBAT,URIBL_SC_SURBL,URIBL_                                          WS_SURBL
            FUZZY_VLIUM,HELO_DYNAMIC_IPADDR,HS_INDEX_PARAM,PYZOR_CHECK,
     2.8 PYZOR_CHECK            Listed in Pyzor (http://pyzor.sf.net/)
    
     

Share This Page