Python version mismatch

Discussion in 'Installation/Configuration' started by pecka33, Oct 11, 2020.

  1. pecka33

    pecka33 Member

    Hello i have a question. I found problem with renew of my lets encrypt. In apache log i fouind that should be maybe because python version. I can see warn
    [Sun Oct 11 00:00:03.848239 2020] [:error] [pid 902] python_init: Python version mismatch, expected '2.7.5+', found '2.7.16'.
    but i am not sure how can i update to new version? I tried apt get update and upgrade, upgrade was a lot of things, but python not.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I don't think that the python version message is related to your problem. Especially as 2.7.16 is newer than 2.7.5, so the rule that the installed python version must be newer than 2.7.5 is matched.
     
  3. pecka33

    pecka33 Member

    Maybe, i think there is new version python 3. But probably have to remove 2 and install 3. In all case before i have no problem with renew lets encrypt. Now lets encrypt expires on 20.11.2020, and for second domain 31.10. I guess that in this time should be both renew. I tried to run manually
    sudo certbot renew --dry-run
    All looks fine and in terminal i can see begin certificate and that it was renew, but files not changed and expires date is still same.
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

Share This Page